{"answers":{"affected":"2 open source packages ship an affected version, including mermaid. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31108 exists.","fix":"Upgrade mermaid to 9.1.2 or later.","what":"CVE-2022-31108 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 28 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-31108 and fix it if it is affected.\n\nWhat it is: CVE-2022-31108 is a medium-severity cross-site scripting vulnerability in mermaid-js mermaid, published on 28 Jun 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31108 exists.\n\nAffected packages and fixed versions:\n- mermaid (npm): affected from 8.0.0; fixed in 9.1.2\n- mermaid (npm): affected from 8.0.0; fixed in 9.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31108/ (Markdown: https://insights.sbomify.com/CVE-2022-31108/index.md)","id":"CVE-2022-31108","markdown":"https://insights.sbomify.com/CVE-2022-31108/index.md","name":"CVE-2022-31108","record":{"aliases":["DEBIAN-CVE-2022-31108","GHSA-x3vm-38hw-55wf","UBUNTU-CVE-2022-31108"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript diagramming library","requires_auth":"low_privilege","summary":"Attackers can inject CSS to exfiltrate data or manipulate UI, affecting users of the mermaid.js diagramming library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"mermaid","vendor":"mermaid_project"}],"cvss":{"score":4.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"Mermaid is a JavaScript based diagramming and charting tool that uses Markdown-inspired text definitions and a renderer to create and modify complex diagrams. An attacker is able to inject arbitrary `CSS` into the generated graph allowing them to change the styling of elements outside of the generated graph, and potentially exfiltrate sensitive information by using specially crafted `CSS` selectors. The following example shows how an attacker can exfiltrate the contents of an input field by bruteforcing the `value` attribute one character at a time. Whenever there is an actual match, an `http` request will be made by the browser in order to \"load\" a background image that will let an attacker know what's the value of the character. This issue may lead to `Information Disclosure` via CSS selectors and functions able to generate HTTP requests. This also allows an attacker to change the document in ways which may lead a user to perform unintended actions, such as clicking on a link, etc. This issue has been resolved in version 9.1.3. Users are advised to upgrade. Users unable to upgrade should ensure that user input is adequately escaped before embedding it in CSS blocks.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Arbitrary `CSS` injection into the generated graph affecting the container HTML in mermaid.js","id":"CVE-2022-31108","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"HTTP Host Header Attack Vulnerability in laminas-diactoros","id":"CVE-2022-31109"},"packages":[{"ecosystem":"npm","fixed":["9.1.2"],"introduced":["8.0.0"],"last_affected":[],"package":"mermaid","purl":null,"source":"GHSA-x3vm-38hw-55wf"},{"ecosystem":"npm","fixed":["9.1.2"],"introduced":["8.0.0"],"last_affected":[],"package":"mermaid","purl":"pkg:npm/mermaid","source":"GHSA-x3vm-38hw-55wf"}],"prev":{"headline":"Grafana account takeover via OAuth vulnerability","id":"CVE-2022-31107"},"products":["mermaid"],"published":"2022-06-28","related":[{"cvss_score":7.2,"headline":"Incorrect sanitisation function leads to `XSS`","id":"CVE-2021-43861","kev_date_added":null,"published":"2021-12-30"},{"cvss_score":6.1,"headline":"Cross-site Scripting in Mermaid","id":"CVE-2021-35513","kev_date_added":null,"published":"2021-06-27"},{"cvss_score":5.3,"headline":"Mermaid Gantt Charts are vulnerable to an Infinite Loop DoS","id":"CVE-2026-41150","kev_date_added":null,"published":"2026-05-29"},{"cvss_score":5.3,"headline":"Mermaid: Improper sanitization of configuration leads to CSS injection","id":"CVE-2026-41159","kev_date_added":null,"published":"2026-05-29"},{"cvss_score":5.1,"headline":"Mermaid does not properly sanitize architecture diagram iconText leading to XSS","id":"CVE-2025-54880","kev_date_added":null,"published":"2025-08-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["mermaid-js"]},"summary":"Attackers can inject CSS to exfiltrate data or manipulate UI, affecting users of the mermaid.js diagramming library.","url":"https://insights.sbomify.com/CVE-2022-31108/"}