{"answers":{"affected":"2 open source packages ship an affected version, including laminas/laminas-diactoros. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31109 in the wild and no public exploit code.","fix":"Upgrade laminas/laminas-diactoros to 2.11.1 or later.","what":"CVE-2022-31109 is a high-severity cross-site scripting vulnerability in laminas-diactoros, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31109 and fix it if it is affected.\n\nWhat it is: CVE-2022-31109 is a high-severity cross-site scripting vulnerability in laminas-diactoros, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31109 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- laminas/laminas-diactoros (Packagist): affected all versions; fixed in 2.11.1\n- laminas/laminas-diactoros (Packagist): affected all versions; fixed in 2.11.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31109/ (Markdown: https://insights.sbomify.com/CVE-2022-31109/index.md)","id":"CVE-2022-31109","markdown":"https://insights.sbomify.com/CVE-2022-31109/index.md","name":"CVE-2022-31109","record":{"aliases":["GHSA-8274-h5jp-97vr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP HTTP library","requires_auth":"none","summary":"Attackers can inject malicious headers to modify URLs, leading to XSS or URL poisoning in applications using this PHP library without proper proxy configuration.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"laminas-diactoros","vendor":"getlaminas"}],"cvss":{"score":7.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"},{"id":"CWE-444","name":"Inconsistent Interpretation of HTTP Requests"}],"description":"laminas-diactoros is a PHP package containing implementations of the PSR-7 HTTP message interfaces and PSR-17 HTTP message factory interfaces. Applications that use Diactoros, and are either not behind a proxy, or can be accessed via untrusted proxies, can potentially have the host, protocol, and/or port of a `Laminas\\Diactoros\\Uri` instance associated with the incoming server request modified to reflect values from `X-Forwarded-*` headers. Such changes can potentially lead to XSS attacks (if a fully-qualified URL is used in links) and/or URL poisoning. Since the `X-Forwarded-*` headers do have valid use cases, particularly in clustered environments using a load balancer, the library offers mitigation measures only in the v2 releases, as doing otherwise would break these use cases immediately. Users of v2 releases from 2.11.1 can provide an additional argument to `Laminas\\Diactoros\\ServerRequestFactory::fromGlobals()` in the form of a `Laminas\\Diactoros\\RequestFilter\\RequestFilterInterface` instance, including the shipped `Laminas\\Diactoros\\RequestFilter\\NoOpRequestFilter` implementation which ignores the `X-Forwarded-*` headers. Starting in version 3.0, the library will reverse behavior to use the `NoOpRequestFilter` by default, and require users to opt-in to `X-Forwarded-*` header usage via a configured `Laminas\\Diactoros\\RequestFilter\\LegacyXForwardedHeaderFilter` instance. Users are advised to upgrade to version 2.11.1 or later to resolve this issue. Users unable to upgrade may configure web servers to reject `X-Forwarded-*` headers at the web server level.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"HTTP Host Header Attack Vulnerability in laminas-diactoros","id":"CVE-2022-31109","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Denial of Service (DoS) vulnerability in RSSHub","id":"CVE-2022-31110"},"packages":[{"ecosystem":"Packagist","fixed":["2.11.1"],"introduced":["0"],"last_affected":[],"package":"laminas/laminas-diactoros","purl":null,"source":"GHSA-8274-h5jp-97vr"},{"ecosystem":"Packagist","fixed":["2.11.1"],"introduced":["0"],"last_affected":[],"package":"laminas/laminas-diactoros","purl":"pkg:composer/laminas/laminas-diactoros","source":"GHSA-8274-h5jp-97vr"}],"prev":{"headline":"Arbitrary `CSS` injection into the generated graph affecting the container HTML in mermaid.js","id":"CVE-2022-31108"},"products":["laminas-diactoros"],"published":"2022-08-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["laminas"]},"summary":"Attackers can inject malicious headers to modify URLs, leading to XSS or URL poisoning in applications using this PHP library without proper proxy configuration.","url":"https://insights.sbomify.com/CVE-2022-31109/"}