# CVE-2022-31109: HTTP Host Header Attack Vulnerability in laminas-diactoros

> Attackers can inject malicious headers to modify URLs, leading to XSS or URL poisoning in applications using this PHP library without proper proxy configuration.

- **Severity:** High 7.2 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-8274-h5jp-97vr

## What is CVE-2022-31109?

CVE-2022-31109 is a high-severity cross-site scripting vulnerability in laminas-diactoros, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

laminas-diactoros is a PHP package containing implementations of the PSR-7 HTTP message interfaces and PSR-17 HTTP message factory interfaces. Applications that use Diactoros, and are either not behind a proxy, or can be accessed via untrusted proxies, can potentially have the host, protocol, and/or port of a `Laminas\Diactoros\Uri` instance associated with the incoming server request modified to reflect values from `X-Forwarded-*` headers. Such changes can potentially lead to XSS attacks (if a fully-qualified URL is used in links) and/or URL poisoning. Since the `X-Forwarded-*` headers do have valid use cases, particularly in clustered environments using a load balancer, the library offers mitigation measures only in the v2 releases, as doing otherwise would break these use cases immediately. Users of v2 releases from 2.11.1 can provide an additional argument to `Laminas\Diactoros\ServerRequestFactory::fromGlobals()` in the form of a `Laminas\Diactoros\RequestFilter\RequestFilterInterface` instance, including the shipped `Laminas\Diactoros\RequestFilter\NoOpRequestFilter` implementation which ignores the `X-Forwarded-*` headers. Starting in version 3.0, the library will reverse behavior to use the `NoOpRequestFilter` by default, and require users to opt-in to `X-Forwarded-*` header usage via a configured `Laminas\Diactoros\RequestFilter\LegacyXForwardedHeaderFilter` instance. Users are advised to upgrade to version 2.11.1 or later to resolve this issue. Users unable to upgrade may configure web servers to reject `X-Forwarded-*` headers at the web server level.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation), CWE-444 (Inconsistent Interpretation of HTTP Requests)

## Which versions are affected by CVE-2022-31109?

2 open source packages ship an affected version, including laminas/laminas-diactoros. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laminas/laminas-diactoros` | Packagist | All versions | 2.11.1 |
| `laminas/laminas-diactoros` | Packagist | All versions | 2.11.1 |

Products: Getlaminas Laminas-Diactoros.

## How do I fix CVE-2022-31109?

Upgrade laminas/laminas-diactoros to 2.11.1 or later.

## Is CVE-2022-31109 being exploited?

There is no known exploitation of CVE-2022-31109 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31109 and fix it if it is affected.

What it is: CVE-2022-31109 is a high-severity cross-site scripting vulnerability in laminas-diactoros, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31109 in the wild and no public exploit code.

Affected packages and fixed versions:
- laminas/laminas-diactoros (Packagist): affected all versions; fixed in 2.11.1
- laminas/laminas-diactoros (Packagist): affected all versions; fixed in 2.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31109/ (Markdown: https://insights.sbomify.com/CVE-2022-31109/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31109
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31109
- OSV: https://osv.dev/vulnerability/CVE-2022-31109

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31109/
Summaries are generated and may contain mistakes; the official description above is the record.
