CVE-2022-31114 backpack/crud Vulnerable to Cross-site Scripting
An attacker can exploit cross-site scripting in the Backpack CRUD package to trick admins into clicking malicious links, potentially gaining admin access or reading sensitive information.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-31114?
CVE-2022-31114 is a medium-severity cross-site scripting vulnerability in Laravel-Backpack CRUD, published on 3 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
backpack/crud provides Create, Read, Update & Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. Versions prior to 5.0.13, 4.1.69, and 4.0.63 are vulnerable to cross-site scripting. An attacker could conduct a targeted phishing campaign, in order to trick users or admins into clicking a malicious link, which under very specific circumstances could give them information or possibly admin access. Versions 5.0.13, 4.1.69, and 4.0.63 patch the issue. As a workaround, manually look inside error views in `resources/views/errors` and output `e($exception->getMessage())` instead of `$exception->getMessage()`.
Weakness: CWE-79
Which versions are affected by CVE-2022-31114?
6 open source packages ship an affected version, including backpack/crud.
| Package | Affected | Fixed in |
|---|---|---|
backpack/crud Packagist | All versions | 4.0.63 |
backpack/crud Packagist | All versions | 4.0.63 |
backpack/crud Packagist | From 4.1.0 | 4.1.69 |
backpack/crud Packagist | From 4.1.0 | 4.1.69 |
backpack/crud Packagist | From 5.0.0 | 5.0.13 |
backpack/crud Packagist | From 5.0.0 | 5.0.13 |
How do I fix CVE-2022-31114?
Upgrade backpack/crud to a fixed version for your release line: 4.0.63, 4.1.69 or 5.0.13.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2022-31114 being exploited?
There is no known exploitation of CVE-2022-31114 in the wild and no public exploit code.
Sources
Also known as GHSA-m8xx-3x29-84h8.