{"answers":{"affected":"6 open source packages ship an affected version, including backpack/crud.","exploited":"There is no known exploitation of CVE-2022-31114 in the wild and no public exploit code.","fix":"Upgrade backpack/crud to a fixed version for your release line: 4.0.63, 4.1.69 or 5.0.13.","what":"CVE-2022-31114 is a medium-severity cross-site scripting vulnerability in Laravel-Backpack CRUD, published on 3 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-31114 and fix it if it is affected.\n\nWhat it is: CVE-2022-31114 is a medium-severity cross-site scripting vulnerability in Laravel-Backpack CRUD, published on 3 Jun 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-31114 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- backpack/crud (Packagist): affected all versions; fixed in 4.0.63\n- backpack/crud (Packagist): affected all versions; fixed in 4.0.63\n- backpack/crud (Packagist): affected from 4.1.0; fixed in 4.1.69\n- backpack/crud (Packagist): affected from 4.1.0; fixed in 4.1.69\n- backpack/crud (Packagist): affected from 5.0.0; fixed in 5.0.13\n- backpack/crud (Packagist): affected from 5.0.0; fixed in 5.0.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31114/ (Markdown: https://insights.sbomify.com/CVE-2022-31114/index.md)","id":"CVE-2022-31114","markdown":"https://insights.sbomify.com/CVE-2022-31114/index.md","name":"CVE-2022-31114","record":{"aliases":["GHSA-m8xx-3x29-84h8"],"analysis":{"component_type":"cms_plugin","fix_type":"patch","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Laravel Backpack CRUD","requires_auth":"none","summary":"An attacker can exploit cross-site scripting in the Backpack CRUD package to trick admins into clicking malicious links, potentially gaining admin access or reading sensitive information.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":5.1,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"backpack/crud provides Create, Read, Update \u0026 Delete (CRUD) functions for Backpack, a collection of Laravel packages that help users build custom administration panels. Versions prior to 5.0.13, 4.1.69, and 4.0.63 are vulnerable to cross-site scripting. An attacker could conduct a targeted phishing campaign, in order to trick users or admins into clicking a malicious link, which under very specific circumstances could give them information or possibly admin access. Versions 5.0.13, 4.1.69, and 4.0.63 patch the issue. As a workaround, manually look inside error views in `resources/views/errors` and output `e($exception-\u003egetMessage())` instead of `$exception-\u003egetMessage()`.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"backpack/crud Vulnerable to Cross-site Scripting","id":"CVE-2022-31114","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":6,"n_references":1,"next":{"headline":"Unsafe YAML deserialization in opensearch-ruby","id":"CVE-2022-31115"},"packages":[{"ecosystem":"Packagist","fixed":["4.0.63"],"introduced":["0"],"last_affected":[],"package":"backpack/crud","purl":null,"source":"GHSA-m8xx-3x29-84h8"},{"ecosystem":"Packagist","fixed":["4.0.63"],"introduced":["0"],"last_affected":[],"package":"backpack/crud","purl":"pkg:composer/backpack/crud","source":"GHSA-m8xx-3x29-84h8"},{"ecosystem":"Packagist","fixed":["4.1.69"],"introduced":["4.1.0"],"last_affected":[],"package":"backpack/crud","purl":null,"source":"GHSA-m8xx-3x29-84h8"},{"ecosystem":"Packagist","fixed":["4.1.69"],"introduced":["4.1.0"],"last_affected":[],"package":"backpack/crud","purl":"pkg:composer/backpack/crud","source":"GHSA-m8xx-3x29-84h8"},{"ecosystem":"Packagist","fixed":["5.0.13"],"introduced":["5.0.0"],"last_affected":[],"package":"backpack/crud","purl":null,"source":"GHSA-m8xx-3x29-84h8"},{"ecosystem":"Packagist","fixed":["5.0.13"],"introduced":["5.0.0"],"last_affected":[],"package":"backpack/crud","purl":"pkg:composer/backpack/crud","source":"GHSA-m8xx-3x29-84h8"}],"prev":{"headline":"Cross-Site Scripting in Canarytoken history","id":"CVE-2022-31113"},"products":["CRUD"],"published":"2026-06-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-03","vendors":["Laravel-Backpack"]},"summary":"An attacker can exploit cross-site scripting in the Backpack CRUD package to trick admins into clicking malicious links, potentially gaining admin access or reading sensitive information.","url":"https://insights.sbomify.com/CVE-2022-31114/"}