CVE-2022-31115 Unsafe YAML deserialization in opensearch-ruby
Unsafe YAML deserialization in the opensearch-ruby library allows code execution if a victim connects to a malicious server.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2022-31115?
CVE-2022-31115 is a high-severity unsafe deserialization vulnerability in opensearch-project opensearch-ruby, published on 30 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
opensearch-ruby is a community-driven, open source fork of elasticsearch-ruby. In versions prior to 2.0.1 the ruby `YAML.load` function was used instead of `YAML.safe_load`. As a result opensearch-ruby 2.0.0 and prior can lead to unsafe deserialization using YAML.load if the response is of type YAML. An attacker must be in control of an opensearch server and convince the victim to connect to it in order to exploit this vulnerability. The problem has been patched in opensearch-ruby gem version 2.0.1. Users are advised to upgrade. There are no known workarounds for this issue.
Weakness: CWE-502
Which versions are affected by CVE-2022-31115?
2 open source packages ship an affected version, including opensearch-ruby. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
opensearch-ruby RubyGems | From 2.0.0 | 2.0.2 |
opensearch-ruby RubyGems | From 2.0.0 | 2.0.2 |
Products include Amazon Opensearch.
How do I fix CVE-2022-31115?
Upgrade opensearch-ruby to 2.0.2 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2022-31115 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31115 exists.
Other vulnerabilities in opensearch-project opensearch-ruby
- CVE-2025-9624 OpenSearch 3.2.0 - Nested Boolean/Disjunction asymmetric DoS
- CVE-2022-35980 OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information
- CVE-2022-41918 Issue with fine-grained access control of indices backing data streams
- CVE-2023-23933 Issue in Anomaly Detection with document and field level rules in numerical feature aggregations
- CVE-2023-23613 Field-level security issue with .keyword fields in OpenSearch
Sources
Also known as GHSA-977c-63xq-cgw3.