# CVE-2022-31115: Unsafe YAML deserialization in opensearch-ruby

> Unsafe YAML deserialization in the opensearch-ruby library allows code execution if a victim connects to a malicious server.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 30 Jun 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-977c-63xq-cgw3

## What is CVE-2022-31115?

CVE-2022-31115 is a high-severity unsafe deserialization vulnerability in opensearch-project opensearch-ruby, published on 30 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

opensearch-ruby is a community-driven, open source fork of elasticsearch-ruby. In versions prior to 2.0.1 the ruby `YAML.load` function was used instead of `YAML.safe_load`. As a result opensearch-ruby 2.0.0 and prior can lead to unsafe deserialization using YAML.load if the response is of type YAML. An attacker must be in control of an opensearch server and convince the victim to connect to it in order to exploit this vulnerability. The problem has been patched in opensearch-ruby gem version 2.0.1. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2022-31115?

2 open source packages ship an affected version, including opensearch-ruby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opensearch-ruby` | RubyGems | From 2.0.0 | 2.0.2 |
| `opensearch-ruby` | RubyGems | From 2.0.0 | 2.0.2 |

Products: Amazon Opensearch.

## How do I fix CVE-2022-31115?

Upgrade opensearch-ruby to 2.0.2 or later.

## Is CVE-2022-31115 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31115 exists.

## Other vulnerabilities in opensearch-project opensearch-ruby

- [CVE-2025-9624](https://insights.sbomify.com/CVE-2025-9624/): OpenSearch 3.2.0 - Nested Boolean/Disjunction asymmetric DoS (high 8.3)
- [CVE-2022-35980](https://insights.sbomify.com/CVE-2022-35980/): OpenSearch vulnerable to Improper Authorization of Index Containing Sensitive Information (high 7.5)
- [CVE-2022-41918](https://insights.sbomify.com/CVE-2022-41918/): Issue with fine-grained access control of indices backing data streams (medium 6.3)
- [CVE-2023-23933](https://insights.sbomify.com/CVE-2023-23933/): Issue in Anomaly Detection with document and field level rules in numerical feature aggregations (medium 5.7)
- [CVE-2023-23613](https://insights.sbomify.com/CVE-2023-23613/): Field-level security issue with .keyword fields in OpenSearch (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31115 and fix it if it is affected.

What it is: CVE-2022-31115 is a high-severity unsafe deserialization vulnerability in opensearch-project opensearch-ruby, published on 30 Jun 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31115 exists.

Affected packages and fixed versions:
- opensearch-ruby (RubyGems): affected from 2.0.0; fixed in 2.0.2
- opensearch-ruby (RubyGems): affected from 2.0.0; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31115/ (Markdown: https://insights.sbomify.com/CVE-2022-31115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31115
- OSV: https://osv.dev/vulnerability/CVE-2022-31115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31115/
Summaries are generated and may contain mistakes; the official description above is the record.
