{"answers":{"affected":"3 open source packages ship an affected version, including ujson. It affects 2 products.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31116 exists.","fix":"Upgrade ujson to 5.4.0 or later.","what":"CVE-2022-31116 is a high-severity vulnerability in Fedoraproject Fedora, published on 5 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31116 and fix it if it is affected.\n\nWhat it is: CVE-2022-31116 is a high-severity vulnerability in Fedoraproject Fedora, published on 5 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31116 exists.\n\nAffected packages and fixed versions:\n- ujson (PyPI): affected all versions; fixed in 5.4.0\n- ujson (PyPI): affected all versions; fixed in 5.4.0\n- ujson (PyPI): affected all versions; fixed in 5.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31116/ (Markdown: https://insights.sbomify.com/CVE-2022-31116/index.md)","id":"CVE-2022-31116","markdown":"https://insights.sbomify.com/CVE-2022-31116/index.md","name":"CVE-2022-31116","record":{"aliases":["DEBIAN-CVE-2022-31116","GHSA-wpqr-jcpx-745r","PYSEC-2026-1057","UBUNTU-CVE-2022-31116"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Python JSON library","requires_auth":"none","summary":"Attackers can corrupt strings and overwrite dictionary values by sending JSON with invalid surrogate pairs to applications using UltraJSON.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"ultrajson","vendor":"ultrajson_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-670","name":"Always-Incorrect Control Flow Implementation"}],"description":"UltraJSON is a fast JSON encoder and decoder written in pure C with bindings for Python 3.7+. Affected versions were found to improperly decode certain characters. JSON strings that contain escaped surrogate characters not part of a proper surrogate pair were decoded incorrectly. Besides corrupting strings, this allowed for potential key confusion and value overwriting in dictionaries. All users parsing JSON from untrusted sources are vulnerable. From version 5.4.0, UltraJSON decodes lone surrogates in the same way as the standard library's `json` module does, preserving them in the parsed output. Users are advised to upgrade. There are no known workarounds for this issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Incorrect handling of invalid surrogate pair characters in ujson","id":"CVE-2022-31116","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"other","year":"2022"},"n_packages":3,"n_references":4,"next":{"headline":"Double free of buffer during string decoding in ujson","id":"CVE-2022-31117"},"packages":[{"ecosystem":"PyPI","fixed":["5.4.0"],"introduced":["0"],"last_affected":[],"package":"ujson","purl":null,"source":"GHSA-wpqr-jcpx-745r"},{"ecosystem":"PyPI","fixed":["5.4.0"],"introduced":["0"],"last_affected":[],"package":"ujson","purl":"pkg:pypi/ujson","source":"GHSA-wpqr-jcpx-745r"},{"ecosystem":"PyPI","fixed":["5.4.0"],"introduced":["0"],"last_affected":[],"package":"ujson","purl":"pkg:pypi/ujson","source":"PYSEC-2026-1057"}],"prev":{"headline":"Unsafe YAML deserialization in opensearch-ruby","id":"CVE-2022-31115"},"products":["ultrajson"],"published":"2022-07-05","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["ultrajson"]},"summary":"Attackers can corrupt strings and overwrite dictionary values by sending JSON with invalid surrogate pairs to applications using UltraJSON.","url":"https://insights.sbomify.com/CVE-2022-31116/"}