{"answers":{"affected":"3 open source packages ship an affected version, including ujson. It affects 2 products.","exploited":"There is no known exploitation of CVE-2022-31117 in the wild and no public exploit code.","fix":"Upgrade ujson to 5.4.0 or later.","what":"CVE-2022-31117 is a medium-severity use after free vulnerability in Fedoraproject Fedora, published on 5 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31117 and fix it if it is affected.\n\nWhat it is: CVE-2022-31117 is a medium-severity use after free vulnerability in Fedoraproject Fedora, published on 5 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31117 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ujson (PyPI): affected all versions; fixed in 5.4.0\n- ujson (PyPI): affected all versions; fixed in 5.4.0\n- ujson (PyPI): affected all versions; fixed in 5.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31117/ (Markdown: https://insights.sbomify.com/CVE-2022-31117/index.md)","id":"CVE-2022-31117","markdown":"https://insights.sbomify.com/CVE-2022-31117/index.md","name":"CVE-2022-31117","record":{"aliases":["DEBIAN-CVE-2022-31117","GHSA-fm67-cv37-96ff","PYSEC-2026-1056","UBUNTU-CVE-2022-31117"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python JSON library","requires_auth":"none","summary":"A double free vulnerability in UltraJSON's C-based decoder could allow attackers to cause denial of service or execute arbitrary code if triggered via internal mechanisms.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"ultrajson","vendor":"ultrajson_project"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-415","name":"Double Free"}],"description":"UltraJSON is a fast JSON encoder and decoder written in pure C with bindings for Python 3.7+. In versions prior to 5.4.0 an error occurring while reallocating a buffer for string decoding can cause the buffer to get freed twice. Due to how UltraJSON uses the internal decoder, this double free is impossible to trigger from Python. This issue has been resolved in version 5.4.0 and all users should upgrade to UltraJSON 5.4.0. There are no known workarounds for this issue.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Double free of buffer during string decoding in ujson","id":"CVE-2022-31117","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"use_after_free","year":"2022"},"n_packages":3,"n_references":4,"next":{"headline":"Missing brute force protection on cloud federation sharing in Nextcloud Server","id":"CVE-2022-31118"},"packages":[{"ecosystem":"PyPI","fixed":["5.4.0"],"introduced":["0"],"last_affected":[],"package":"ujson","purl":null,"source":"GHSA-fm67-cv37-96ff"},{"ecosystem":"PyPI","fixed":["5.4.0"],"introduced":["0"],"last_affected":[],"package":"ujson","purl":"pkg:pypi/ujson","source":"GHSA-fm67-cv37-96ff"},{"ecosystem":"PyPI","fixed":["5.4.0"],"introduced":["0"],"last_affected":[],"package":"ujson","purl":"pkg:pypi/ujson","source":"PYSEC-2026-1056"}],"prev":{"headline":"Incorrect handling of invalid surrogate pair characters in ujson","id":"CVE-2022-31116"},"products":["ultrajson"],"published":"2022-07-05","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["ultrajson"]},"summary":"A double free vulnerability in UltraJSON's C-based decoder could allow attackers to cause denial of service or execute arbitrary code if triggered via internal mechanisms.","url":"https://insights.sbomify.com/CVE-2022-31117/"}