# CVE-2022-31117: Double free of buffer during string decoding in ujson

> A double free vulnerability in UltraJSON's C-based decoder could allow attackers to cause denial of service or execute arbitrary code if triggered via internal mechanisms.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jul 2022
- **Updated:** 23 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-31117, GHSA-fm67-cv37-96ff, PYSEC-2026-1056, UBUNTU-CVE-2022-31117

## What is CVE-2022-31117?

CVE-2022-31117 is a medium-severity use after free vulnerability in Fedoraproject Fedora, published on 5 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

UltraJSON is a fast JSON encoder and decoder written in pure C with bindings for Python 3.7+. In versions prior to 5.4.0 an error occurring while reallocating a buffer for string decoding can cause the buffer to get freed twice. Due to how UltraJSON uses the internal decoder, this double free is impossible to trigger from Python. This issue has been resolved in version 5.4.0 and all users should upgrade to UltraJSON 5.4.0. There are no known workarounds for this issue.

Weakness: CWE-415 (Double Free)

## Which versions are affected by CVE-2022-31117?

3 open source packages ship an affected version, including ujson. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ujson` | PyPI | All versions | 5.4.0 |
| `ujson` | PyPI | All versions | 5.4.0 |
| `ujson` | PyPI | All versions | 5.4.0 |

Products: Fedoraproject Fedora, Ultrajson Project Ultrajson.

## How do I fix CVE-2022-31117?

Upgrade ujson to 5.4.0 or later.

## Is CVE-2022-31117 being exploited?

There is no known exploitation of CVE-2022-31117 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31117 and fix it if it is affected.

What it is: CVE-2022-31117 is a medium-severity use after free vulnerability in Fedoraproject Fedora, published on 5 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31117 in the wild and no public exploit code.

Affected packages and fixed versions:
- ujson (PyPI): affected all versions; fixed in 5.4.0
- ujson (PyPI): affected all versions; fixed in 5.4.0
- ujson (PyPI): affected all versions; fixed in 5.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31117/ (Markdown: https://insights.sbomify.com/CVE-2022-31117/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31117
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31117
- OSV: https://osv.dev/vulnerability/CVE-2022-31117

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31117/
Summaries are generated and may contain mistakes; the official description above is the record.
