# CVE-2022-31123: Grafana plugin signature bypass vulnerability

> Attackers can bypass plugin signature checks to install malicious plugins, leading to code execution if admins install them.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:L/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Oct 2022
- **Updated:** 28 Jan 2026
- **Also known as:** BIT-grafana-2022-31123, GHSA-rhxj-gh46-jvw8, GO-2024-2855, MINI-4p29-87x5-x2f3, MINI-649c-p9pf-8433, MINI-66wv-ff2x-3v28, MINI-6hpm-hm5j-xgc4, MINI-83wp-v44r-q6gx, MINI-969j-jqcw-qc62, MINI-9gg8-q9vh-rrjx, MINI-g6q8-v62v-r648, MINI-g84q-2jgw-wr34, MINI-hmj2-38mx-5cqv, MINI-hwc2-8chr-4cw2, MINI-m6px-34c9-74q3, MINI-rp67-777h-h4w9, MINI-v5r6-cq7m-v2px, MINI-vc3f-mqm3-mhc6, MINI-x9vf-cxxm-7jrm, MINI-xf46-xc5m-jj2h, UBUNTU-CVE-2022-31123

## What is CVE-2022-31123?

CVE-2022-31123 is a medium-severity vulnerability in Grafana Grafana, published on 13 Oct 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Grafana is an open source observability and data visualization platform. Versions prior to 9.1.8 and 8.5.14 are vulnerable to a bypass in the plugin signature verification. An attacker can convince a server admin to download and successfully run a malicious plugin even though unsigned plugins are not allowed. Versions 9.1.8 and 8.5.14 contain a patch for this issue. As a workaround, do not install plugins downloaded from untrusted sources.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2022-31123?

6 open source packages ship an affected version, including github.com/grafana/grafana and grafana. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grafana/grafana` | Go | All versions | None |
| `github.com/grafana/grafana` | Go | From 7.0.0 | 8.5.14 |
| `github.com/grafana/grafana` | Go | From 7.0.0 | 8.5.14 |
| `github.com/grafana/grafana` | Go | From 9.0.0 | 9.1.8 |
| `github.com/grafana/grafana` | Go | From 9.0.0 | 9.1.8 |
| `grafana` | Bitnami | From 7.0.0 | 8.5.14, 9.1.8 |

Products: Grafana Grafana, Netapp E-Series Performance Analyzer.

## How do I fix CVE-2022-31123?

Upgrade github.com/grafana/grafana to a fixed version for your release line: 8.5.14 or 9.1.8.

## Is CVE-2022-31123 being exploited?

There is no known exploitation of CVE-2022-31123 in the wild and no public exploit code.

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31123 and fix it if it is affected.

What it is: CVE-2022-31123 is a medium-severity vulnerability in Grafana Grafana, published on 13 Oct 2022. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-31123 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grafana/grafana (Go): affected all versions; no fix listed
- github.com/grafana/grafana (Go): affected from 7.0.0; fixed in 8.5.14
- github.com/grafana/grafana (Go): affected from 7.0.0; fixed in 8.5.14
- github.com/grafana/grafana (Go): affected from 9.0.0; fixed in 9.1.8
- github.com/grafana/grafana (Go): affected from 9.0.0; fixed in 9.1.8
- grafana (Bitnami): affected from 7.0.0; fixed in 8.5.14, 9.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31123/ (Markdown: https://insights.sbomify.com/CVE-2022-31123/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31123
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31123
- OSV: https://osv.dev/vulnerability/CVE-2022-31123

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31123/
Summaries are generated and may contain mistakes; the official description above is the record.
