{"answers":{"affected":"4 open source packages ship an affected version, including next-auth. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31127 exists.","fix":"Upgrade next-auth to a fixed version for your release line: 3.29.8 or 4.9.0.","what":"CVE-2022-31127 is a high-severity cross-site scripting vulnerability in nextauthjs next-auth, published on 6 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-31127 and fix it if it is affected.\n\nWhat it is: CVE-2022-31127 is a high-severity cross-site scripting vulnerability in nextauthjs next-auth, published on 6 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31127 exists.\n\nAffected packages and fixed versions:\n- next-auth (npm): affected all versions; fixed in 3.29.8\n- next-auth (npm): affected all versions; fixed in 3.29.8\n- next-auth (npm): affected from 4.0.0; fixed in 4.9.0\n- next-auth (npm): affected from 4.0.0; fixed in 4.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31127/ (Markdown: https://insights.sbomify.com/CVE-2022-31127/index.md)","id":"CVE-2022-31127","markdown":"https://insights.sbomify.com/CVE-2022-31127/index.md","name":"CVE-2022-31127","record":{"aliases":["GHSA-pgjx-7f9g-9463"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Next.js authentication library","requires_auth":"none","summary":"Attackers can inject malicious HTML into verification emails via the email input, enabling phishing attacks against users of NextAuth.js.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"next-auth","vendor":"nextauth.js"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"NextAuth.js is a complete open source authentication solution for Next.js applications. An attacker can pass a compromised input to the e-mail [signin endpoint](https://next-auth.js.org/getting-started/rest-api#post-apiauthsigninprovider) that contains some malicious HTML, tricking the e-mail server to send it to the user, so they can perform a phishing attack. Eg.: `balazs@email.com, \u003ca href=\"http://attacker.com\"\u003eBefore signing in, claim your money!\u003c/a\u003e`. This was previously sent to `balazs@email.com`, and the content of the email containing a link to the attacker's site was rendered in the HTML. This has been remedied in the following releases, by simply not rendering that e-mail in the HTML, since it should be obvious to the receiver what e-mail they used: next-auth v3 users before version 3.29.8 are impacted. (We recommend upgrading to v4, as v3 is considered unmaintained. next-auth v4 users before version 4.9.0 are impacted. If for some reason you cannot upgrade, the workaround requires you to sanitize the `email` parameter that is passed to `sendVerificationRequest` and rendered in the HTML. If you haven't created a custom `sendVerificationRequest`, you only need to upgrade. Otherwise, make sure to either exclude `email` from the HTML body or efficiently sanitize it.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Improper handling of email input in next-auth","id":"CVE-2022-31127","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2022"},"n_packages":4,"n_references":5,"next":{"headline":"Fine grained permissions are not checked in Tuleap","id":"CVE-2022-31128"},"packages":[{"ecosystem":"npm","fixed":["3.29.8"],"introduced":["0"],"last_affected":[],"package":"next-auth","purl":null,"source":"GHSA-pgjx-7f9g-9463"},{"ecosystem":"npm","fixed":["3.29.8"],"introduced":["0"],"last_affected":[],"package":"next-auth","purl":"pkg:npm/next-auth","source":"GHSA-pgjx-7f9g-9463"},{"ecosystem":"npm","fixed":["4.9.0"],"introduced":["4.0.0"],"last_affected":[],"package":"next-auth","purl":null,"source":"GHSA-pgjx-7f9g-9463"},{"ecosystem":"npm","fixed":["4.9.0"],"introduced":["4.0.0"],"last_affected":[],"package":"next-auth","purl":"pkg:npm/next-auth","source":"GHSA-pgjx-7f9g-9463"}],"prev":{"headline":"Unauthenticated Remote Code Execution in Roxy-wi","id":"CVE-2022-31126"},"products":["next-auth"],"published":"2022-07-06","related":[{"cvss_score":9.1,"headline":"Verification requests (magic link) sent to unwanted emails","id":"CVE-2022-35924","kev_date_added":null,"published":"2022-08-02"},{"cvss_score":8.1,"headline":"Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth","id":"CVE-2023-27490","kev_date_added":null,"published":"2023-03-09"},{"cvss_score":7.5,"headline":"Improper Handling of `callbackUrl` parameter in next-auth","id":"CVE-2022-31093","kev_date_added":null,"published":"2022-06-27"},{"cvss_score":6.8,"headline":"NextAuth.js Upstash Adapter missing token verification","id":"CVE-2022-39263","kev_date_added":null,"published":"2022-09-28"},{"cvss_score":6.1,"headline":"URL Redirection to Untrusted Site ('Open Redirect') in next-auth","id":"CVE-2022-29214","kev_date_added":null,"published":"2022-05-20"},{"cvss_score":6.1,"headline":"Default redirect callback vulnerable to open redirects","id":"CVE-2022-24858","kev_date_added":null,"published":"2022-04-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["nextauthjs"]},"summary":"Attackers can inject malicious HTML into verification emails via the email input, enabling phishing attacks against users of NextAuth.js.","url":"https://insights.sbomify.com/CVE-2022-31127/"}