# CVE-2022-31130: Grafana data source and plugin proxy endpoints leaking authentication tokens to some destination plugins

> Attackers can leak Grafana authentication tokens to destination plugins via proxy endpoints, potentially enabling unauthorized access.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-grafana-2022-31130, CLSA-2025-1751142388, GHSA-jv32-5578-pxjc, GO-2024-2851, MINI-27m5-pj8h-867c, MINI-2pvw-c63g-qv2v, MINI-72w3-4x3p-cpm7, MINI-789m-whr4-gf2p, MINI-8fxc-vg38-mfx7, MINI-h9q5-qwqr-6q6x, MINI-mwgf-cgmc-f89x, MINI-mxg4-962p-88hf, MINI-p74r-cwv5-7f8r, MINI-qrx9-mjwr-r8rf, MINI-v2w6-j352-9vqq, MINI-w22r-hx5x-456q, MINI-wh69-vvv2-9pqm, MINI-wj6m-2pcx-jf4x, MINI-ww86-c24q-crvm, MINI-x7qc-x7fq-pwmv, MINI-x9hg-x85j-hv3g, UBUNTU-CVE-2022-31130

## What is CVE-2022-31130?

CVE-2022-31130 is a medium-severity vulnerability in Grafana Grafana, published on 13 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Grafana is an open source observability and data visualization platform. Versions of Grafana for endpoints prior to 9.1.8 and 8.5.14 could leak authentication tokens to some destination plugins under some conditions. The vulnerability impacts data source and plugin proxy endpoints with authentication tokens. The destination plugin could receive a user's Grafana authentication token. Versions 9.1.8 and 8.5.14 contain a patch for this issue. As a workaround, do not use API keys, JWT authentication, or any HTTP Header based authentication.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-31130?

6 open source packages ship an affected version, including github.com/grafana/grafana and grafana. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/grafana/grafana` | Go | All versions | None |
| `github.com/grafana/grafana` | Go | From 7.0.0 | 8.5.14 |
| `github.com/grafana/grafana` | Go | From 7.0.0 | 8.5.14 |
| `github.com/grafana/grafana` | Go | From 9.0.0 | 9.1.8 |
| `github.com/grafana/grafana` | Go | From 9.0.0 | 9.1.8 |
| `grafana` | Bitnami | All versions | 8.5.14, 9.1.8 |

Products: Grafana Grafana.

## How do I fix CVE-2022-31130?

Upgrade github.com/grafana/grafana to a fixed version for your release line: 8.5.14 or 9.1.8.

## Is CVE-2022-31130 being exploited?

There is no known exploitation of CVE-2022-31130 in the wild and no public exploit code.

## Other vulnerabilities in Grafana Grafana

- [CVE-2021-43798](https://insights.sbomify.com/CVE-2021-43798/): Grafana Path Traversal (high 7.5, exploited in the wild)
- [CVE-2025-41115](https://insights.sbomify.com/CVE-2025-41115/): Incorrect privilege assignment (critical 10.0)
- [CVE-2022-39328](https://insights.sbomify.com/CVE-2022-39328/): Grafana vulnerable to race condition allowing privilege escalation (critical 9.8)
- [CVE-2022-28660](https://insights.sbomify.com/CVE-2022-28660/): Auth bypass in n/a (critical 9.8)
- [CVE-2022-26148](https://insights.sbomify.com/CVE-2022-26148/): Information disclosure in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31130 and fix it if it is affected.

What it is: CVE-2022-31130 is a medium-severity vulnerability in Grafana Grafana, published on 13 Oct 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31130 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/grafana/grafana (Go): affected all versions; no fix listed
- github.com/grafana/grafana (Go): affected from 7.0.0; fixed in 8.5.14
- github.com/grafana/grafana (Go): affected from 7.0.0; fixed in 8.5.14
- github.com/grafana/grafana (Go): affected from 9.0.0; fixed in 9.1.8
- github.com/grafana/grafana (Go): affected from 9.0.0; fixed in 9.1.8
- grafana (Bitnami): affected all versions; fixed in 8.5.14, 9.1.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31130/ (Markdown: https://insights.sbomify.com/CVE-2022-31130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31130
- OSV: https://osv.dev/vulnerability/CVE-2022-31130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31130/
Summaries are generated and may contain mistakes; the official description above is the record.
