{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31136 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2022-31136 yet. Limit exposure of the affected software until one is available.","what":"CVE-2022-31136 is a medium-severity cross-site scripting vulnerability in bookwyrm-social bookwyrm, published on 7 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-31136 and fix it if it is affected.\n\nWhat it is: CVE-2022-31136 is a medium-severity cross-site scripting vulnerability in bookwyrm-social bookwyrm, published on 7 Jul 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-31136 in the wild and no public exploit code.\n\nAffected product: bookwyrm-social bookwyrm. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31136/ (Markdown: https://insights.sbomify.com/CVE-2022-31136/index.md)","id":"CVE-2022-31136","markdown":"https://insights.sbomify.com/CVE-2022-31136/index.md","name":"CVE-2022-31136","record":{"aliases":["GHSA-2cfh-v7rf-pxfp"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"BookWyrm social reading","requires_auth":"none","summary":"Unprivileged users can inject scripts into profiles and statuses, enabling cross-site scripting attacks against other users.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"bookwyrm","vendor":"joinbookwyrm"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Bookwyrm is an open source social reading and reviewing program. Versions of Bookwyrm prior to 0.4.1 did not properly sanitize html being rendered to users. Unprivileged users are able to inject scripts into user profiles, book descriptions, and statuses. These vulnerabilities may be exploited as cross site scripting attacks on users viewing these fields. Users are advised to upgrade to version 0.4.1. There are no known workarounds for this issue.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Cross-site Scripting in BookWyrm","id":"CVE-2022-31136","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2022"},"n_packages":0,"n_references":2,"next":{"headline":"Unauthenticated Remote Code Execution in Roxy-WI","id":"CVE-2022-31137"},"packages":[],"prev":{"headline":"Maliciously crafted evidence packet may cause denial of service","id":"CVE-2022-31135"},"products":["bookwyrm"],"published":"2022-07-07","related":[{"cvss_score":9.8,"headline":"Authentication Bypass by Primary Weakness in bookwyrm-social/bookwyrm","id":"CVE-2022-2651","kev_date_added":null,"published":"2022-08-04"},{"cvss_score":8.8,"headline":"Server-side request forgery in BookWyrm","id":"CVE-2022-23644","kev_date_added":null,"published":"2022-02-16"},{"cvss_score":7.1,"headline":"URL Redirection to Untrusted Site ('Open Redirect') in bookwyrm","id":"CVE-2022-35953","kev_date_added":null,"published":"2022-08-12"},{"cvss_score":5.3,"headline":"Missing rate limit in Authentication in bookwyrm","id":"CVE-2022-35925","kev_date_added":null,"published":"2022-08-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["bookwyrm-social"]},"summary":"Unprivileged users can inject scripts into profiles and statuses, enabling cross-site scripting attacks against other users.","url":"https://insights.sbomify.com/CVE-2022-31136/"}