{"answers":{"affected":"2 open source packages ship an affected version, including io.github.karlatemp:unsafe-accessor. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31139 in the wild and no public exploit code.","fix":"Upgrade io.github.karlatemp:unsafe-accessor to 1.7.0 or later.","what":"CVE-2022-31139 is a medium-severity vulnerability in Karlatemp UnsafeAccessor, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31139 and fix it if it is affected.\n\nWhat it is: CVE-2022-31139 is a medium-severity vulnerability in Karlatemp UnsafeAccessor, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31139 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.github.karlatemp:unsafe-accessor (Maven): affected from 1.4.0; fixed in 1.7.0\n- io.github.karlatemp:unsafe-accessor (Maven): affected from 1.4.0; fixed in 1.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31139/ (Markdown: https://insights.sbomify.com/CVE-2022-31139/index.md)","id":"CVE-2022-31139","markdown":"https://insights.sbomify.com/CVE-2022-31139/index.md","name":"CVE-2022-31139","record":{"aliases":["GHSA-cr6p-23cf-w9g9"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Java Unsafe Accessor","requires_auth":"none","summary":"Untrusted code can bypass access restrictions on UnsafeAccessor when a specific security limiter is configured, allowing unauthorized access to internal data.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"unsafe_accessor","vendor":"unsafe_accessor_project"}],"cvss":{"score":5.9,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"UnsafeAccessor (UA) is a bridge to access jdk.internal.misc.Unsafe \u0026 sun.misc.Unsafe. Normally, if UA is loaded as a named module, the internal data of UA is protected by JVM and others can only access UA via UA's standard API. The main application can set up `SecurityCheck.AccessLimiter` for UA to limit access to UA. Starting with version 1.4.0 and prior to version 1.7.0, when `SecurityCheck.AccessLimiter` is set up, untrusted code can access UA without limitation, even when UA is loaded as a named module. This issue does not affect those for whom `SecurityCheck.AccessLimiter` is not set up. Version 1.7.0 contains a patch.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"No security checking for UnsafeAccess.getInstance() in UnsafeAccessor","id":"CVE-2022-31139","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Valinor error messages leading to potential data exfiltration","id":"CVE-2022-31140"},"packages":[{"ecosystem":"Maven","fixed":["1.7.0"],"introduced":["1.4.0"],"last_affected":[],"package":"io.github.karlatemp:unsafe-accessor","purl":null,"source":"GHSA-cr6p-23cf-w9g9"},{"ecosystem":"Maven","fixed":["1.7.0"],"introduced":["1.4.0"],"last_affected":[],"package":"io.github.karlatemp:unsafe-accessor","purl":"pkg:maven/io.github.karlatemp/unsafe-accessor","source":"GHSA-cr6p-23cf-w9g9"}],"prev":{"headline":"OS Command Injection in mailcow","id":"CVE-2022-31138"},"products":["UnsafeAccessor"],"published":"2022-07-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["Karlatemp"]},"summary":"Untrusted code can bypass access restrictions on UnsafeAccessor when a specific security limiter is configured, allowing unauthorized access to internal data.","url":"https://insights.sbomify.com/CVE-2022-31139/"}