{"answers":{"affected":"2 open source packages ship an affected version, including cuyz/valinor. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31140 exists.","fix":"Upgrade cuyz/valinor to 0.12.0 or later.","what":"CVE-2022-31140 is a high-severity vulnerability in CuyZ Valinor, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31140 and fix it if it is affected.\n\nWhat it is: CVE-2022-31140 is a high-severity vulnerability in CuyZ Valinor, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31140 exists.\n\nAffected packages and fixed versions:\n- cuyz/valinor (Packagist): affected all versions; fixed in 0.12.0\n- cuyz/valinor (Packagist): affected all versions; fixed in 0.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31140/ (Markdown: https://insights.sbomify.com/CVE-2022-31140/index.md)","id":"CVE-2022-31140","markdown":"https://insights.sbomify.com/CVE-2022-31140/index.md","name":"CVE-2022-31140","record":{"aliases":["GHSA-5pgm-3j3g-2rc7"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","other"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP mapping library","requires_auth":"none","summary":"Attackers can extract sensitive data like database credentials or SQL snippets via error messages in the Valinor PHP library.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"valinor","vendor":"cuyz"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"Valinor is a PHP library that helps to map any input into a strongly-typed value object structure. Prior to version 0.12.0, Valinor can use `Throwable#getMessage()` when it should not have permission to do so. This is a problem with cases such as an SQL exception showing an SQL snippet, a database connection exception showing database IP address/username/password, or a timeout detail / out of memory detail. Attackers could use this information for potential data exfiltration, denial of service attacks, enumeration attacks, etc. Version 0.12.0 contains a patch for this vulnerability.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Valinor error messages leading to potential data exfiltration","id":"CVE-2022-31140","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"information_disclosure","year":"2022"},"n_packages":2,"n_references":2,"next":{"headline":"Potential Timing Attack Vector in @fastify/bearer-auth","id":"CVE-2022-31142"},"packages":[{"ecosystem":"Packagist","fixed":["0.12.0"],"introduced":["0"],"last_affected":[],"package":"cuyz/valinor","purl":null,"source":"GHSA-5pgm-3j3g-2rc7"},{"ecosystem":"Packagist","fixed":["0.12.0"],"introduced":["0"],"last_affected":[],"package":"cuyz/valinor","purl":"pkg:composer/cuyz/valinor","source":"GHSA-5pgm-3j3g-2rc7"}],"prev":{"headline":"No security checking for UnsafeAccess.getInstance() in UnsafeAccessor","id":"CVE-2022-31139"},"products":["Valinor"],"published":"2022-07-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["CuyZ"]},"summary":"Attackers can extract sensitive data like database credentials or SQL snippets via error messages in the Valinor PHP library.","url":"https://insights.sbomify.com/CVE-2022-31140/"}