# CVE-2022-31140: Valinor error messages leading to potential data exfiltration

> Attackers can extract sensitive data like database credentials or SQL snippets via error messages in the Valinor PHP library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jul 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-5pgm-3j3g-2rc7

## What is CVE-2022-31140?

CVE-2022-31140 is a high-severity vulnerability in CuyZ Valinor, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Valinor is a PHP library that helps to map any input into a strongly-typed value object structure. Prior to version 0.12.0, Valinor can use `Throwable#getMessage()` when it should not have permission to do so. This is a problem with cases such as an SQL exception showing an SQL snippet, a database connection exception showing database IP address/username/password, or a timeout detail / out of memory detail. Attackers could use this information for potential data exfiltration, denial of service attacks, enumeration attacks, etc. Version 0.12.0 contains a patch for this vulnerability.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2022-31140?

2 open source packages ship an affected version, including cuyz/valinor. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cuyz/valinor` | Packagist | All versions | 0.12.0 |
| `cuyz/valinor` | Packagist | All versions | 0.12.0 |

Products: Cuyz Valinor.

## How do I fix CVE-2022-31140?

Upgrade cuyz/valinor to 0.12.0 or later.

## Is CVE-2022-31140 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31140 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31140 and fix it if it is affected.

What it is: CVE-2022-31140 is a high-severity vulnerability in CuyZ Valinor, published on 11 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31140 exists.

Affected packages and fixed versions:
- cuyz/valinor (Packagist): affected all versions; fixed in 0.12.0
- cuyz/valinor (Packagist): affected all versions; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31140/ (Markdown: https://insights.sbomify.com/CVE-2022-31140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31140
- OSV: https://osv.dev/vulnerability/CVE-2022-31140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31140/
Summaries are generated and may contain mistakes; the official description above is the record.
