# CVE-2022-31142: Potential Timing Attack Vector in @fastify/bearer-auth

> A timing attack in the Fastify bearer auth plugin allows attackers to estimate valid token lengths, facilitating brute-force attacks against authentication.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-376v-xgjx-7mfr

## What is CVE-2022-31142?

CVE-2022-31142 is a high-severity vulnerability in fastify-bearer-auth, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

@fastify/bearer-auth is a Fastify plugin to require bearer Authorization headers. @fastify/bearer-auth prior to versions 7.0.2 and 8.0.1 does not securely use crypto.timingSafeEqual. A malicious attacker could estimate the length of one valid bearer token. According to the corresponding RFC 6750, the bearer token has only base64 valid characters, reducing the range of characters for a brute force attack. Version 7.0.2 and 8.0.1 of @fastify/bearer-auth contain a patch. There are currently no known workarounds. The package fastify-bearer-auth, which covers versions 6.0.3 and prior, is also vulnerable starting at version 5.0.1. Users of fastify-bearer-auth should upgrade to a patched version of @fastify/bearer-auth.

Weakness: CWE-203 (Observable Discrepancy), CWE-208 (Observable Timing Discrepancy)

## Which versions are affected by CVE-2022-31142?

6 open source packages ship an affected version, including fastify-bearer-auth and @fastify/bearer-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fastify-bearer-auth` | npm | From 5.0.1 to 6.0.3 | None |
| `fastify-bearer-auth` | npm | From 5.0.1 to 6.0.3 | None |
| `@fastify/bearer-auth` | npm | All versions | 7.0.2 |
| `@fastify/bearer-auth` | npm | All versions | 7.0.2 |
| `@fastify/bearer-auth` | npm | From 8.0.0 | 8.0.1 |
| `@fastify/bearer-auth` | npm | From 8.0.0 | 8.0.1 |

Products: Fastify Bearer-Auth.

## How do I fix CVE-2022-31142?

Upgrade to a fixed version.

## Is CVE-2022-31142 being exploited?

There is no known exploitation of CVE-2022-31142 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31142 and fix it if it is affected.

What it is: CVE-2022-31142 is a high-severity vulnerability in fastify-bearer-auth, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31142 in the wild and no public exploit code.

Affected packages and fixed versions:
- fastify-bearer-auth (npm): affected from 5.0.1 up to 6.0.3; no fix listed
- fastify-bearer-auth (npm): affected from 5.0.1 up to 6.0.3; no fix listed
- @fastify/bearer-auth (npm): affected all versions; fixed in 7.0.2
- @fastify/bearer-auth (npm): affected all versions; fixed in 7.0.2
- @fastify/bearer-auth (npm): affected from 8.0.0; fixed in 8.0.1
- @fastify/bearer-auth (npm): affected from 8.0.0; fixed in 8.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31142/ (Markdown: https://insights.sbomify.com/CVE-2022-31142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31142
- OSV: https://osv.dev/vulnerability/CVE-2022-31142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31142/
Summaries are generated and may contain mistakes; the official description above is the record.
