CVE-2022-31144 Potential heap overflow in Redis

High 7.0 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2022-31144?

CVE-2022-31144 is a high-severity vulnerability in redis, published on 19 Jul 2022.

Official description

Redis is an in-memory database that persists on disk. A specially crafted `XAUTOCLAIM` command on a stream key in a specific state may result with heap overflow, and potentially remote code execution. This problem affects versions on the 7.x branch prior to 7.0.4. The patch is released in version 7.0.4.

Weakness: CWE-787, CWE-122

Which versions are affected by CVE-2022-31144?

3 open source packages ship an affected version, including redis, keydb and valkey. It affects 1 product.

PackageAffectedFixed in
redis BitnamiFrom 7.0.07.0.4
keydb BitnamiFrom 7.0.07.0.4
valkey BitnamiFrom 7.0.07.0.4
Linux distribution packages (1)
redis openSUSE:TumbleweedAll versions7.0.4-1.1

Products include Redis Redis.

How do I fix CVE-2022-31144?

Upgrade redis to 7.0.4 or later.

Is CVE-2022-31144 being exploited?

There is no known exploitation of CVE-2022-31144 in the wild and no public exploit code.

Public exploit code: 1 proofs of concept on GitHub.

Sources

Also known as ALPINE-CVE-2022-31144, BIT-keydb-2022-31144, BIT-redis-2022-31144, BIT-valkey-2022-31144, CLEANSTART-2026-XS03344, DEBIAN-CVE-2022-31144 and 2 more.

Is CVE-2022-31144 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free