# CVE-2022-31144: Potential heap overflow in Redis


- **Severity:** High 7.0 (`CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 19 Jul 2022
- **Updated:** 23 Apr 2025
- **Also known as:** ALPINE-CVE-2022-31144, BIT-keydb-2022-31144, BIT-redis-2022-31144, BIT-valkey-2022-31144, CLEANSTART-2026-XS03344, DEBIAN-CVE-2022-31144, GHSA-96f7-42fg-2jrh, openSUSE-SU-2024:12217-1

## What is CVE-2022-31144?

CVE-2022-31144 is a high-severity vulnerability in redis, published on 19 Jul 2022. 

### Official description

Redis is an in-memory database that persists on disk. A specially crafted `XAUTOCLAIM` command on a stream key in a specific state may result with heap overflow, and potentially remote code execution. This problem affects versions on the 7.x branch prior to 7.0.4. The patch is released in version 7.0.4.

Weakness: CWE-787 (Out-of-bounds Write), CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2022-31144?

3 open source packages ship an affected version, including redis, keydb and valkey. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `redis` | Bitnami | From 7.0.0 | 7.0.4 |
| `keydb` | Bitnami | From 7.0.0 | 7.0.4 |
| `valkey` | Bitnami | From 7.0.0 | 7.0.4 |
| `redis` | openSUSE:Tumbleweed | All versions | 7.0.4-1.1 |

Products: Redis Redis.

## How do I fix CVE-2022-31144?

Upgrade redis to 7.0.4 or later.

## Is CVE-2022-31144 being exploited?

There is no known exploitation of CVE-2022-31144 in the wild and no public exploit code.

Public exploit code:

- CVE-2022-31144 dos pt redis, not finished yet or too soon, this can be turned into rce but oh well if you smart enough (github_poc): https://github.com/SpiralBL0CK/CVE-2022-31144

## Other vulnerabilities in redis

- [CVE-2022-0543](https://insights.sbomify.com/CVE-2022-0543/): Debian-specific Redis Server Lua Sandbox Escape (critical 10.0, exploited in the wild)
- [CVE-2026-23479](https://insights.sbomify.com/CVE-2026-23479/): redis-server use-after-free in unblock client flow may allow remote code execution (high 7.7)
- [CVE-2026-25243](https://insights.sbomify.com/CVE-2026-25243/): redis-server RESTORE invalid memory access may allow remote code execution (high 7.7)
- [CVE-2025-62507](https://insights.sbomify.com/CVE-2025-62507/): Redis: Bug in XACKDEL may lead to stack overflow and potential RCE (high 7.7)
- [CVE-2025-48367](https://insights.sbomify.com/CVE-2025-48367/): Redis DoS Vulnerability due to bad connection error handling (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31144 and fix it if it is affected.

What it is: CVE-2022-31144 is a high-severity vulnerability in redis, published on 19 Jul 2022. 
Exploitation: There is no known exploitation of CVE-2022-31144 in the wild and no public exploit code.

Affected packages and fixed versions:
- redis (Bitnami): affected from 7.0.0; fixed in 7.0.4
- keydb (Bitnami): affected from 7.0.0; fixed in 7.0.4
- valkey (Bitnami): affected from 7.0.0; fixed in 7.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31144/ (Markdown: https://insights.sbomify.com/CVE-2022-31144/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31144
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31144
- OSV: https://osv.dev/vulnerability/CVE-2022-31144

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31144/
Summaries are generated and may contain mistakes; the official description above is the record.
