{"answers":{"affected":"3 open source packages ship an affected version, including github.com/flyteorg/flyteadmin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31145 in the wild and no public exploit code.","fix":"Upgrade github.com/flyteorg/flyteadmin to 1.1.31 or later.","what":"CVE-2022-31145 is a medium-severity authentication bypass vulnerability in flyteorg flyteadmin, published on 13 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31145 and fix it if it is affected.\n\nWhat it is: CVE-2022-31145 is a medium-severity authentication bypass vulnerability in flyteorg flyteadmin, published on 13 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31145 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.31\n- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.31\n- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.31\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31145/ (Markdown: https://insights.sbomify.com/CVE-2022-31145/index.md)","id":"CVE-2022-31145","markdown":"https://insights.sbomify.com/CVE-2022-31145/index.md","name":"CVE-2022-31145","record":{"aliases":["GHSA-qwrj-9hmp-gpxh","GO-2022-0519"],"analysis":{"component_type":"server_software","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"FlyteAdmin control plane","requires_auth":"low_privilege","summary":"Authenticated users can bypass token expiration checks to maintain access, requiring external identity provider configuration.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"flyteadmin","vendor":"flyte"}],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"FlyteAdmin is the control plane for Flyte responsible for managing entities and administering workflow executions. In versions 1.1.30 and prior, authenticated users using an external identity provider can continue to use Access Tokens and ID Tokens even after they expire. Users who use FlyteAdmin as the OAuth2 Authorization Server are unaffected by this issue. A patch is available on the `master` branch of the repository. As a workaround, rotating signing keys immediately will invalidate all open sessions and force all users to attempt to obtain new tokens. Those who use this workaround should continue to rotate keys until FlyteAdmin has been upgraded and hide FlyteAdmin deployment ingress URL from the internet.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insufficient AccessToken Expiration Check in FlyteAdmin","id":"CVE-2022-31145","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"auth_bypass","year":"2022"},"n_packages":3,"n_references":3,"next":{"headline":"Use After Free in Wasmtime","id":"CVE-2022-31146"},"packages":[{"ecosystem":"Go","fixed":["1.1.31"],"introduced":["0"],"last_affected":[],"package":"github.com/flyteorg/flyteadmin","purl":null,"source":"GHSA-qwrj-9hmp-gpxh"},{"ecosystem":"Go","fixed":["1.1.31"],"introduced":["0"],"last_affected":[],"package":"github.com/flyteorg/flyteadmin","purl":"pkg:golang/github.com/flyteorg/flyteadmin","source":"GHSA-qwrj-9hmp-gpxh"},{"ecosystem":"Go","fixed":["1.1.31"],"introduced":["0"],"last_affected":[],"package":"github.com/flyteorg/flyteadmin","purl":"pkg:golang/github.com/flyteorg/flyteadmin","source":"GO-2022-0519"}],"prev":{"headline":"Potential heap overflow in Redis","id":"CVE-2022-31144"},"products":["flyteadmin"],"published":"2022-07-13","related":[{"cvss_score":4.8,"headline":"Default OAuth Authorization Server secret in FlyteAdmin","id":"CVE-2022-39273","kev_date_added":null,"published":"2022-10-06"},{"cvss_score":3.5,"headline":"FlyteAdmin SQL Injection in List Filters","id":"CVE-2023-41891","kev_date_added":null,"published":"2023-10-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["flyteorg"]},"summary":"Authenticated users can bypass token expiration checks to maintain access, requiring external identity provider configuration.","url":"https://insights.sbomify.com/CVE-2022-31145/"}