# CVE-2022-31145: Insufficient AccessToken Expiration Check in FlyteAdmin

> Authenticated users can bypass token expiration checks to maintain access, requiring external identity provider configuration.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-qwrj-9hmp-gpxh, GO-2022-0519

## What is CVE-2022-31145?

CVE-2022-31145 is a medium-severity authentication bypass vulnerability in flyteorg flyteadmin, published on 13 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

FlyteAdmin is the control plane for Flyte responsible for managing entities and administering workflow executions. In versions 1.1.30 and prior, authenticated users using an external identity provider can continue to use Access Tokens and ID Tokens even after they expire. Users who use FlyteAdmin as the OAuth2 Authorization Server are unaffected by this issue. A patch is available on the `master` branch of the repository. As a workaround, rotating signing keys immediately will invalidate all open sessions and force all users to attempt to obtain new tokens. Those who use this workaround should continue to rotate keys until FlyteAdmin has been upgraded and hide FlyteAdmin deployment ingress URL from the internet.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2022-31145?

3 open source packages ship an affected version, including github.com/flyteorg/flyteadmin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/flyteorg/flyteadmin` | Go | All versions | 1.1.31 |
| `github.com/flyteorg/flyteadmin` | Go | All versions | 1.1.31 |
| `github.com/flyteorg/flyteadmin` | Go | All versions | 1.1.31 |

Products: Flyte Flyteadmin.

## How do I fix CVE-2022-31145?

Upgrade github.com/flyteorg/flyteadmin to 1.1.31 or later.

## Is CVE-2022-31145 being exploited?

There is no known exploitation of CVE-2022-31145 in the wild and no public exploit code.

## Other vulnerabilities in flyteorg flyteadmin

- [CVE-2022-39273](https://insights.sbomify.com/CVE-2022-39273/): Default OAuth Authorization Server secret in FlyteAdmin (medium 4.8)
- [CVE-2023-41891](https://insights.sbomify.com/CVE-2023-41891/): FlyteAdmin SQL Injection in List Filters (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31145 and fix it if it is affected.

What it is: CVE-2022-31145 is a medium-severity authentication bypass vulnerability in flyteorg flyteadmin, published on 13 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31145 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.31
- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.31
- github.com/flyteorg/flyteadmin (Go): affected all versions; fixed in 1.1.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31145/ (Markdown: https://insights.sbomify.com/CVE-2022-31145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31145
- OSV: https://osv.dev/vulnerability/CVE-2022-31145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31145/
Summaries are generated and may contain mistakes; the official description above is the record.
