{"answers":{"affected":"2 open source packages ship an affected version, including jquery-validation. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31147 in the wild and no public exploit code.","fix":"Upgrade jquery-validation to 1.19.5 or later.","what":"CVE-2022-31147 is a high-severity denial of service vulnerability in jquery-validation, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31147 and fix it if it is affected.\n\nWhat it is: CVE-2022-31147 is a high-severity denial of service vulnerability in jquery-validation, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31147 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- jquery-validation (npm): affected all versions; fixed in 1.19.5\n- jquery-validation (npm): affected all versions; fixed in 1.19.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31147/ (Markdown: https://insights.sbomify.com/CVE-2022-31147/index.md)","id":"CVE-2022-31147","markdown":"https://insights.sbomify.com/CVE-2022-31147/index.md","name":"CVE-2022-31147","record":{"aliases":["GHSA-ffmh-x56j-9rc3","UBUNTU-CVE-2022-31147"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"jQuery validation library","requires_auth":"none","summary":"An attacker can cause a denial of service in applications using the jQuery Validation Plugin by supplying malicious input to the url2 method.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"jquery_validation","vendor":"jqueryvalidation"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-1333","name":"Inefficient Regular Expression Complexity"}],"description":"The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":"2025-09-02","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-09-02T11:11:47Z","kind":"github_poc","ref":"https://github.com/amhar-hckr/Webapp_Pentast","stars":0,"title":"CVE-2022-31147 is a path traversal flaw in matthiasmullie/minify. This guide helps security teams test for arbitrary file read on Linux and Windows using Python and curl. It covers automated payload generation, manual validation, and safe practices for vulnerability assessment."}],"tier":"poc_unverified"},"has_fix":true,"headline":"jquery-validation ReDoS in url2 due to incomplete fix of CVE-2021-43306","id":"CVE-2022-31147","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Persistent cross site scripting in customer module in Shopware","id":"CVE-2022-31148"},"packages":[{"ecosystem":"npm","fixed":["1.19.5"],"introduced":["0"],"last_affected":[],"package":"jquery-validation","purl":null,"source":"GHSA-ffmh-x56j-9rc3"},{"ecosystem":"npm","fixed":["1.19.5"],"introduced":["0"],"last_affected":[],"package":"jquery-validation","purl":"pkg:npm/jquery-validation","source":"GHSA-ffmh-x56j-9rc3"}],"prev":{"headline":"Use After Free in Wasmtime","id":"CVE-2022-31146"},"products":["jquery-validation"],"published":"2022-07-14","related":[{"cvss_score":5.9,"headline":"Exponential ReDoS in jquery-validation","id":"CVE-2021-43306","kev_date_added":null,"published":"2022-06-01"},{"cvss_score":5.3,"headline":"Regular expression denial of service in jquery-validation","id":"CVE-2021-21252","kev_date_added":null,"published":"2021-01-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["jquery-validation"]},"summary":"An attacker can cause a denial of service in applications using the jQuery Validation Plugin by supplying malicious input to the url2 method.","url":"https://insights.sbomify.com/CVE-2022-31147/"}