# CVE-2022-31147: jquery-validation ReDoS in url2 due to incomplete fix of CVE-2021-43306

> An attacker can cause a denial of service in applications using the jQuery Validation Plugin by supplying malicious input to the url2 method.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jul 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-ffmh-x56j-9rc3, UBUNTU-CVE-2022-31147

## What is CVE-2022-31147?

CVE-2022-31147 is a high-severity denial of service vulnerability in jquery-validation, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The jQuery Validation Plugin (jquery-validation) provides drop-in validation for forms. Versions of jquery-validation prior to 1.19.5 are vulnerable to regular expression denial of service (ReDoS) when an attacker is able to supply arbitrary input to the url2 method. This is due to an incomplete fix for CVE-2021-43306. Users should upgrade to version 1.19.5 to receive a patch.

Weakness: CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2022-31147?

2 open source packages ship an affected version, including jquery-validation. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jquery-validation` | npm | All versions | 1.19.5 |
| `jquery-validation` | npm | All versions | 1.19.5 |

Products: Jqueryvalidation Jquery Validation.

## How do I fix CVE-2022-31147?

Upgrade jquery-validation to 1.19.5 or later.

## Is CVE-2022-31147 being exploited?

There is no known exploitation of CVE-2022-31147 in the wild and no public exploit code.

Public exploit code:

- CVE-2022-31147 is a path traversal flaw in matthiasmullie/minify. This guide helps security teams test for arbitrary file read on Linux and Windows using Python and curl. It covers automated payload generation, manual validation, and safe practices for vulnerability assessment. (github_poc): https://github.com/amhar-hckr/Webapp_Pentast

## Other vulnerabilities in jquery-validation

- [CVE-2021-43306](https://insights.sbomify.com/CVE-2021-43306/): Exponential ReDoS in jquery-validation (medium 5.9)
- [CVE-2021-21252](https://insights.sbomify.com/CVE-2021-21252/): Regular expression denial of service in jquery-validation (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31147 and fix it if it is affected.

What it is: CVE-2022-31147 is a high-severity denial of service vulnerability in jquery-validation, published on 14 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31147 in the wild and no public exploit code.

Affected packages and fixed versions:
- jquery-validation (npm): affected all versions; fixed in 1.19.5
- jquery-validation (npm): affected all versions; fixed in 1.19.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31147/ (Markdown: https://insights.sbomify.com/CVE-2022-31147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31147
- OSV: https://osv.dev/vulnerability/CVE-2022-31147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31147/
Summaries are generated and may contain mistakes; the official description above is the record.
