CVE-2022-31148 Persistent cross site scripting in customer module in Shopware

Medium 5.4 Published Updated

Attackers can inject persistent scripts into the customer module, potentially stealing sessions or executing code in victim browsers.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2022-31148?

CVE-2022-31148 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 1 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Shopware is an open source e-commerce software. In versions from 5.7.0 a persistent cross site scripting (XSS) vulnerability exists in the customer module. Users are recommend to update to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.

Weakness: CWE-79

Which versions are affected by CVE-2022-31148?

2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.

PackageAffectedFixed in
shopware/shopware PackagistFrom 5.7.05.7.14
shopware/shopware PackagistFrom 5.7.05.7.14

Products include Shopware Shopware.

How do I fix CVE-2022-31148?

Upgrade shopware/shopware to 5.7.14 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2022-31148 being exploited?

There is no known exploitation of CVE-2022-31148 in the wild and no public exploit code.

All Shopware Shopware vulnerabilities

Sources

Also known as GHSA-5834-xv5q-cgfw.

Is CVE-2022-31148 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free