{"answers":{"affected":"2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31148 in the wild and no public exploit code.","fix":"Upgrade shopware/shopware to 5.7.14 or later.","what":"CVE-2022-31148 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 1 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2022-31148 and fix it if it is affected.\n\nWhat it is: CVE-2022-31148 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 1 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2022-31148 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- shopware/shopware (Packagist): affected from 5.7.0; fixed in 5.7.14\n- shopware/shopware (Packagist): affected from 5.7.0; fixed in 5.7.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31148/ (Markdown: https://insights.sbomify.com/CVE-2022-31148/index.md)","id":"CVE-2022-31148","markdown":"https://insights.sbomify.com/CVE-2022-31148/index.md","name":"CVE-2022-31148","record":{"aliases":["GHSA-5834-xv5q-cgfw"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Shopware e-commerce","requires_auth":"low_privilege","summary":"Attackers can inject persistent scripts into the customer module, potentially stealing sessions or executing code in victim browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"shopware","vendor":"shopware"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Shopware is an open source e-commerce software. In versions from 5.7.0 a persistent cross site scripting (XSS) vulnerability exists in the customer module. Users are recommend to update to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Persistent cross site scripting in customer module in Shopware","id":"CVE-2022-31148","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"shopware:shopware","products":["shopware:shopware"],"type":"xss","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"ActivityWatch vulnerable to DNS rebinding attack","id":"CVE-2022-31149"},"packages":[{"ecosystem":"Packagist","fixed":["5.7.14"],"introduced":["5.7.0"],"last_affected":[],"package":"shopware/shopware","purl":null,"source":"GHSA-5834-xv5q-cgfw"},{"ecosystem":"Packagist","fixed":["5.7.14"],"introduced":["5.7.0"],"last_affected":[],"package":"shopware/shopware","purl":"pkg:composer/shopware/shopware","source":"GHSA-5834-xv5q-cgfw"}],"prev":{"headline":"jquery-validation ReDoS in url2 due to incomplete fix of CVE-2021-43306","id":"CVE-2022-31147"},"products":["shopware"],"published":"2022-08-01","related":[{"cvss_score":10,"headline":"Improper Control of Generation of Code in Twig rendered views in shopware","id":"CVE-2023-22731","kev_date_added":null,"published":"2023-01-17"},{"cvss_score":9.8,"headline":"Shopware RCE Vulnerability","id":"CVE-2016-3109","kev_date_added":null,"published":"2017-04-21"},{"cvss_score":9.3,"headline":"Blind SQL-injection in DAL aggregations in Shopware","id":"CVE-2024-22406","kev_date_added":null,"published":"2024-01-16"},{"cvss_score":9.1,"headline":"Leak of information via Store-API","id":"CVE-2021-32711","kev_date_added":null,"published":"2021-06-24"},{"cvss_score":8.9,"headline":"Shopware unauthenticated data extraction possible through store-api.order endpoint","id":"CVE-2026-31887","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":8.9,"headline":"Shopware has a potential take over of app credentials","id":"CVE-2026-31889","kev_date_added":null,"published":"2026-03-11"},{"cvss_score":8.8,"headline":"Improper Control of Generation of Code in Twig Rendered Views in Shopware","id":"CVE-2023-2017","kev_date_added":null,"published":"2023-04-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["shopware"]},"summary":"Attackers can inject persistent scripts into the customer module, potentially stealing sessions or executing code in victim browsers.","url":"https://insights.sbomify.com/CVE-2022-31148/"}