# CVE-2022-31148: Persistent cross site scripting in customer module in Shopware

> Attackers can inject persistent scripts into the customer module, potentially stealing sessions or executing code in victim browsers.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-5834-xv5q-cgfw

## What is CVE-2022-31148?

CVE-2022-31148 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 1 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Shopware is an open source e-commerce software. In versions from 5.7.0 a persistent cross site scripting (XSS) vulnerability exists in the customer module. Users are recommend to update to the current version 5.7.14. You can get the update to 5.7.14 regularly via the Auto-Updater or directly via the download overview. There are no known workarounds for this issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2022-31148?

2 open source packages ship an affected version, including shopware/shopware. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `shopware/shopware` | Packagist | From 5.7.0 | 5.7.14 |
| `shopware/shopware` | Packagist | From 5.7.0 | 5.7.14 |

Products: Shopware Shopware.

## How do I fix CVE-2022-31148?

Upgrade shopware/shopware to 5.7.14 or later.

## Is CVE-2022-31148 being exploited?

There is no known exploitation of CVE-2022-31148 in the wild and no public exploit code.

## Other vulnerabilities in Shopware Shopware

- [CVE-2023-22731](https://insights.sbomify.com/CVE-2023-22731/): Improper Control of Generation of Code in Twig rendered views in shopware (critical 10.0)
- [CVE-2016-3109](https://insights.sbomify.com/CVE-2016-3109/): Shopware RCE Vulnerability (critical 9.8)
- [CVE-2024-22406](https://insights.sbomify.com/CVE-2024-22406/): Blind SQL-injection in DAL aggregations in Shopware (critical 9.3)
- [CVE-2021-32711](https://insights.sbomify.com/CVE-2021-32711/): Leak of information via Store-API (critical 9.1)
- [CVE-2026-31887](https://insights.sbomify.com/CVE-2026-31887/): Shopware unauthenticated data extraction possible through store-api.order endpoint (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31148 and fix it if it is affected.

What it is: CVE-2022-31148 is a medium-severity cross-site scripting vulnerability in Shopware Shopware, published on 1 Aug 2022. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-31148 in the wild and no public exploit code.

Affected packages and fixed versions:
- shopware/shopware (Packagist): affected from 5.7.0; fixed in 5.7.14
- shopware/shopware (Packagist): affected from 5.7.0; fixed in 5.7.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31148/ (Markdown: https://insights.sbomify.com/CVE-2022-31148/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31148
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31148
- OSV: https://osv.dev/vulnerability/CVE-2022-31148

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31148/
Summaries are generated and may contain mistakes; the official description above is the record.
