# CVE-2022-31150: CRLF injection in request headers

> Attackers can inject CRLF sequences into HTTP request headers, potentially leading to header injection or cache poisoning in applications using undici.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jul 2022
- **Updated:** 22 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-31150, GHSA-3cvr-822r-rqcc, UBUNTU-CVE-2022-31150

## What is CVE-2022-31150?

CVE-2022-31150 is a medium-severity vulnerability in Nodejs Undici, published on 19 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

undici is an HTTP/1.1 client, written from scratch for Node.js. It is possible to inject CRLF sequences into request headers in undici in versions less than 5.7.1. A fix was released in version 5.8.0. Sanitizing all HTTP headers from untrusted sources to eliminate `\r\n` is a workaround for this issue.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences)

## Which versions are affected by CVE-2022-31150?

2 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | All versions | 5.8.0 |
| `undici` | npm | All versions | 5.8.0 |

Products: Nodejs Undici.

## How do I fix CVE-2022-31150?

Upgrade undici to 5.8.0 or later.

## Is CVE-2022-31150 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31150 exists.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31150 and fix it if it is affected.

What it is: CVE-2022-31150 is a medium-severity vulnerability in Nodejs Undici, published on 19 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31150 exists.

Affected packages and fixed versions:
- undici (npm): affected all versions; fixed in 5.8.0
- undici (npm): affected all versions; fixed in 5.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31150/ (Markdown: https://insights.sbomify.com/CVE-2022-31150/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31150
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31150
- OSV: https://osv.dev/vulnerability/CVE-2022-31150

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31150/
Summaries are generated and may contain mistakes; the official description above is the record.
