{"answers":{"affected":"2 open source packages ship an affected version, including undici. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31151 exists.","fix":"Upgrade undici to 5.8.0 or later.","what":"CVE-2022-31151 is a low-severity vulnerability in Nodejs Undici, published on 20 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31151 and fix it if it is affected.\n\nWhat it is: CVE-2022-31151 is a low-severity vulnerability in Nodejs Undici, published on 20 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31151 exists.\n\nAffected packages and fixed versions:\n- undici (npm): affected all versions; fixed in 5.8.0\n- undici (npm): affected all versions; fixed in 5.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31151/ (Markdown: https://insights.sbomify.com/CVE-2022-31151/index.md)","id":"CVE-2022-31151","markdown":"https://insights.sbomify.com/CVE-2022-31151/index.md","name":"CVE-2022-31151","record":{"aliases":["DEBIAN-CVE-2022-31151","GHSA-q768-x9m6-m9qp","UBUNTU-CVE-2022-31151"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js HTTP client","requires_auth":"none","summary":"Attackers can leak sensitive cookies to third-party sites via cross-origin redirects if redirection is enabled in the undici library.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"undici","vendor":"nodejs"}],"cvss":{"score":3.7,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-346","name":"Origin Validation Error"},{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"Authorization headers are cleared on cross-origin redirect. However, cookie headers which are sensitive headers and are official headers found in the spec, remain uncleared. There are active users using cookie headers in undici. This may lead to accidental leakage of cookie to a 3rd-party site or a malicious attacker who can control the redirection target (ie. an open redirector) to leak the cookie to the 3rd party site. This was patched in v5.7.1. By default, this vulnerability is not exploitable. Do not enable redirections, i.e. `maxRedirections: 0` (the default).","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Uncleared cookies on cross-host/cross-origin redirect in undici","id":"CVE-2022-31151","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"nodejs:undici","products":["nodejs:undici"],"type":"information_disclosure","year":"2022"},"n_packages":2,"n_references":4,"next":{"headline":"Synapse vulnerable to denial of service (DoS) due to incorrect application of event authorization rules","id":"CVE-2022-31152"},"packages":[{"ecosystem":"npm","fixed":["5.8.0"],"introduced":["0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-q768-x9m6-m9qp"},{"ecosystem":"npm","fixed":["5.8.0"],"introduced":["0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-q768-x9m6-m9qp"}],"prev":{"headline":"CRLF injection in request headers","id":"CVE-2022-31150"},"products":["undici"],"published":"2022-07-20","related":[{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake","id":"CVE-2026-109855","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via unhandled error on excessive content-encodings","id":"CVE-2026-109869","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation","id":"CVE-2026-87018","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via unrequested WebSocket subprotocol","id":"CVE-2026-19534","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to denial of service via fragment count bypass","id":"CVE-2026-12151","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":7.5,"headline":"undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse","id":"CVE-2026-6734","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to denial of service via cumulative fragment bypass","id":"CVE-2026-9675","kev_date_added":null,"published":"2026-06-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["nodejs"]},"summary":"Attackers can leak sensitive cookies to third-party sites via cross-origin redirects if redirection is enabled in the undici library.","url":"https://insights.sbomify.com/CVE-2022-31151/"}