# CVE-2022-31151: Uncleared cookies on cross-host/cross-origin redirect in undici

> Attackers can leak sensitive cookies to third-party sites via cross-origin redirects if redirection is enabled in the undici library.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2022
- **Updated:** 22 Apr 2025
- **Also known as:** DEBIAN-CVE-2022-31151, GHSA-q768-x9m6-m9qp, UBUNTU-CVE-2022-31151

## What is CVE-2022-31151?

CVE-2022-31151 is a low-severity vulnerability in Nodejs Undici, published on 20 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authorization headers are cleared on cross-origin redirect. However, cookie headers which are sensitive headers and are official headers found in the spec, remain uncleared. There are active users using cookie headers in undici. This may lead to accidental leakage of cookie to a 3rd-party site or a malicious attacker who can control the redirection target (ie. an open redirector) to leak the cookie to the 3rd party site. This was patched in v5.7.1. By default, this vulnerability is not exploitable. Do not enable redirections, i.e. `maxRedirections: 0` (the default).

Weakness: CWE-346 (Origin Validation Error), CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2022-31151?

2 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | All versions | 5.8.0 |
| `undici` | npm | All versions | 5.8.0 |

Products: Nodejs Undici.

## How do I fix CVE-2022-31151?

Upgrade undici to 5.8.0 or later.

## Is CVE-2022-31151 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31151 exists.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31151 and fix it if it is affected.

What it is: CVE-2022-31151 is a low-severity vulnerability in Nodejs Undici, published on 20 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31151 exists.

Affected packages and fixed versions:
- undici (npm): affected all versions; fixed in 5.8.0
- undici (npm): affected all versions; fixed in 5.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31151/ (Markdown: https://insights.sbomify.com/CVE-2022-31151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31151
- OSV: https://osv.dev/vulnerability/CVE-2022-31151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31151/
Summaries are generated and may contain mistakes; the official description above is the record.
