CVE-2022-31152 Synapse vulnerable to denial of service (DoS) due to incorrect application of event authorization rules

Medium 6.4 Published Updated

Attackers can cause room state divergence and denial of service in Synapse homeservers with federation enabled by exploiting incorrect event authorization rules.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2022-31152?

CVE-2022-31152 is a medium-severity denial of service vulnerability in matrix-org synapse, published on 2 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. The Matrix specification specifies a list of [event authorization rules](https://spec.matrix.org/v1.2/rooms/v9/#authorization-rules) which must be checked when determining if an event should be accepted into a room. In versions of Synapse up to and including version 1.61.0, some of these rules are not correctly applied. An attacker could craft events which would be accepted by Synapse but not a spec-conformant server, potentially causing divergence in the room state between servers. Administrators of homeservers with federation enabled are advised to upgrade to version 1.62.0 or higher. Federation can be disabled by setting [`federation_domain_whitelist`](https://matrix-org.github.io/synapse/latest/usage/configuration/config_documentation.html#federation_domain_whitelist) to an empty list (`[]`) as a workaround.

Weakness: CWE-755, CWE-703

Which versions are affected by CVE-2022-31152?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.

PackageAffectedFixed in
matrix-synapse PyPIAll versions1.62.0
matrix-synapse PyPIAll versions1.62.0rc1
matrix-synapse PyPIAll versions1.62.0rc1

Products include Matrix Synapse.

How do I fix CVE-2022-31152?

Upgrade matrix-synapse to a fixed version for your release line: 1.62.0 or 1.62.0rc1.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2022-31152 being exploited?

There is no known exploitation of CVE-2022-31152 in the wild and no public exploit code.

Sources

Also known as GHSA-jhjh-776m-4765, PYSEC-2022-262, UBUNTU-CVE-2022-31152.

Is CVE-2022-31152 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free