# CVE-2022-31152: Synapse vulnerable to denial of service (DoS) due to incorrect application of event authorization rules

> Attackers can cause room state divergence and denial of service in Synapse homeservers with federation enabled by exploiting incorrect event authorization rules.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-jhjh-776m-4765, PYSEC-2022-262, UBUNTU-CVE-2022-31152

## What is CVE-2022-31152?

CVE-2022-31152 is a medium-severity denial of service vulnerability in matrix-org synapse, published on 2 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Synapse is an open-source Matrix homeserver written and maintained by the Matrix.org Foundation. The Matrix specification specifies a list of [event authorization rules](https://spec.matrix.org/v1.2/rooms/v9/#authorization-rules) which must be checked when determining if an event should be accepted into a room. In versions of Synapse up to and including version 1.61.0, some of these rules are not correctly applied. An attacker could craft events which would be accepted by Synapse but not a spec-conformant server, potentially causing divergence in the room state between servers. Administrators of homeservers with federation enabled are advised to upgrade to version 1.62.0 or higher. Federation can be disabled by setting [`federation_domain_whitelist`](https://matrix-org.github.io/synapse/latest/usage/configuration/config_documentation.html#federation_domain_whitelist) to an empty list (`[]`) as a workaround.

Weakness: CWE-755 (Improper Handling of Exceptional Conditions), CWE-703 (Improper Check or Handling of Exceptional Conditions)

## Which versions are affected by CVE-2022-31152?

3 open source packages ship an affected version, including matrix-synapse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `matrix-synapse` | PyPI | All versions | 1.62.0 |
| `matrix-synapse` | PyPI | All versions | 1.62.0rc1 |
| `matrix-synapse` | PyPI | All versions | 1.62.0rc1 |

Products: Matrix Synapse.

## How do I fix CVE-2022-31152?

Upgrade matrix-synapse to a fixed version for your release line: 1.62.0 or 1.62.0rc1.

## Is CVE-2022-31152 being exploited?

There is no known exploitation of CVE-2022-31152 in the wild and no public exploit code.

## Other vulnerabilities in matrix-org synapse

- [CVE-2019-18835](https://insights.sbomify.com/CVE-2019-18835/): Improper Verification of Cryptographic Signature in matrix-synapse (critical 9.8)
- [CVE-2024-52815](https://insights.sbomify.com/CVE-2024-52815/): Synapse allows a a malformed invite to break the invitee's `/sync` (high 8.7)
- [CVE-2024-52805](https://insights.sbomify.com/CVE-2024-52805/): Synapse allows unsupported content types to lead to memory exhaustion (high 8.2)
- [CVE-2024-53863](https://insights.sbomify.com/CVE-2024-53863/): Synapse can be forced to thumbnail unexpected file formats, invoking external, potentially untrustworthy decoders (high 8.2)
- [CVE-2024-37302](https://insights.sbomify.com/CVE-2024-37302/): Synapse denial of service through media disk space consumption (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31152 and fix it if it is affected.

What it is: CVE-2022-31152 is a medium-severity denial of service vulnerability in matrix-org synapse, published on 2 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31152 in the wild and no public exploit code.

Affected packages and fixed versions:
- matrix-synapse (PyPI): affected all versions; fixed in 1.62.0
- matrix-synapse (PyPI): affected all versions; fixed in 1.62.0rc1
- matrix-synapse (PyPI): affected all versions; fixed in 1.62.0rc1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31152/ (Markdown: https://insights.sbomify.com/CVE-2022-31152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31152
- OSV: https://osv.dev/vulnerability/CVE-2022-31152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31152/
Summaries are generated and may contain mistakes; the official description above is the record.
