{"answers":{"affected":"2 open source packages ship an affected version, including packbackbooks/lti-1-3-php-library. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31158 in the wild and no public exploit code.","fix":"Upgrade packbackbooks/lti-1-3-php-library to 5.0 or later.","what":"CVE-2022-31158 is a high-severity vulnerability in packbackbooks lti-1-3-php-library, published on 15 Jul 2022."},"fix_prompt":"Check this codebase for CVE-2022-31158 and fix it if it is affected.\n\nWhat it is: CVE-2022-31158 is a high-severity vulnerability in packbackbooks lti-1-3-php-library, published on 15 Jul 2022. \nExploitation: There is no known exploitation of CVE-2022-31158 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- packbackbooks/lti-1-3-php-library (Packagist): affected all versions; fixed in 5.0\n- packbackbooks/lti-1-3-php-library (Packagist): affected all versions; fixed in 5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31158/ (Markdown: https://insights.sbomify.com/CVE-2022-31158/index.md)","id":"CVE-2022-31158","markdown":"https://insights.sbomify.com/CVE-2022-31158/index.md","name":"CVE-2022-31158","record":{"aliases":["GHSA-5p73-qg2v-383h"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"lti_1.3_tool_library","vendor":"packback"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-294","name":"Authentication Bypass by Capture-replay"}],"description":"LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authentication Bypass by Capture-replay in packbackbooks/lti-1-3-php-library","id":"CVE-2022-31158","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":null,"year":"2022"},"n_packages":2,"n_references":1,"next":{"headline":"Partial Path Traversal in com.amazonaws:aws-java-sdk-s3","id":"CVE-2022-31159"},"packages":[{"ecosystem":"Packagist","fixed":["5.0"],"introduced":["0"],"last_affected":[],"package":"packbackbooks/lti-1-3-php-library","purl":null,"source":"GHSA-5p73-qg2v-383h"},{"ecosystem":"Packagist","fixed":["5.0"],"introduced":["0"],"last_affected":[],"package":"packbackbooks/lti-1-3-php-library","purl":"pkg:composer/packbackbooks/lti-1-3-php-library","source":"GHSA-5p73-qg2v-383h"}],"prev":{"headline":"Use of a Broken or Risky Cryptographic Algorithm in packbackbooks/lti-1-3-php-library","id":"CVE-2022-31157"},"products":["lti-1-3-php-library"],"published":"2022-07-15","related":[{"cvss_score":7.5,"headline":"Use of a Broken or Risky Cryptographic Algorithm in packbackbooks/lti-1-3-php-library","id":"CVE-2022-31157","kev_date_added":null,"published":"2022-07-15"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["packbackbooks"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2022-31158/"}