# CVE-2022-31158: Authentication Bypass by Capture-replay in packbackbooks/lti-1-3-php-library


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 15 Jul 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-5p73-qg2v-383h

## What is CVE-2022-31158?

CVE-2022-31158 is a high-severity vulnerability in packbackbooks lti-1-3-php-library, published on 15 Jul 2022. 

### Official description

LTI 1.3 Tool Library is a library used for building IMS-certified LTI 1.3 tool providers in PHP. Prior to version 5.0, the Nonce Claim Value was not being validated against the nonce value sent in the Authentication Request. Users should upgrade to version 5.0 to receive a patch. There are currently no known workarounds.

Weakness: CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2022-31158?

2 open source packages ship an affected version, including packbackbooks/lti-1-3-php-library. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `packbackbooks/lti-1-3-php-library` | Packagist | All versions | 5.0 |
| `packbackbooks/lti-1-3-php-library` | Packagist | All versions | 5.0 |

Products: Packback Lti 1.3 Tool Library.

## How do I fix CVE-2022-31158?

Upgrade packbackbooks/lti-1-3-php-library to 5.0 or later.

## Is CVE-2022-31158 being exploited?

There is no known exploitation of CVE-2022-31158 in the wild and no public exploit code.

## Other vulnerabilities in packbackbooks lti-1-3-php-library

- [CVE-2022-31157](https://insights.sbomify.com/CVE-2022-31157/): Use of a Broken or Risky Cryptographic Algorithm in packbackbooks/lti-1-3-php-library (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31158 and fix it if it is affected.

What it is: CVE-2022-31158 is a high-severity vulnerability in packbackbooks lti-1-3-php-library, published on 15 Jul 2022. 
Exploitation: There is no known exploitation of CVE-2022-31158 in the wild and no public exploit code.

Affected packages and fixed versions:
- packbackbooks/lti-1-3-php-library (Packagist): affected all versions; fixed in 5.0
- packbackbooks/lti-1-3-php-library (Packagist): affected all versions; fixed in 5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31158/ (Markdown: https://insights.sbomify.com/CVE-2022-31158/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31158
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31158
- OSV: https://osv.dev/vulnerability/CVE-2022-31158

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31158/
Summaries are generated and may contain mistakes; the official description above is the record.
