# CVE-2022-31164: Tovy before v0.7.51 vulnerable to users logging in as and impersonating other users

> Attackers can impersonate other users, including administrators, in the Tovy staff management system for Roblox groups.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Jul 2022
- **Updated:** 23 Apr 2025

## What is CVE-2022-31164?

CVE-2022-31164 is a high-severity authentication bypass vulnerability in tovyblox tovy, published on 21 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Tovy is a a staff management system for Roblox groups. A vulnerability in versions prior to 0.7.51 allows users to log in as other users, including privileged users such as the other of the instance. The problem has been patched in version 0.7.51.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2022-31164?

It affects 1 product.


Products: Tovyblox Tovy.

## How do I fix CVE-2022-31164?

No fix has been published for CVE-2022-31164 yet. Limit exposure of the affected software until one is available.

## Is CVE-2022-31164 being exploited?

There is no known exploitation of CVE-2022-31164 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31164 and fix it if it is affected.

What it is: CVE-2022-31164 is a high-severity authentication bypass vulnerability in tovyblox tovy, published on 21 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31164 in the wild and no public exploit code.

Affected product: tovyblox tovy. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31164/ (Markdown: https://insights.sbomify.com/CVE-2022-31164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31164
- OSV: https://osv.dev/vulnerability/CVE-2022-31164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31164/
Summaries are generated and may contain mistakes; the official description above is the record.
