# CVE-2022-31166: XWiki.WebHome vulnerable to Improper Privilege Management in XWiki resolving groups

> Attackers can escalate privileges by exploiting a group resolution bug in XWikiRights, allowing unauthorized access to protected resources.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-g4h6-qp44-wqvx

## What is CVE-2022-31166?

CVE-2022-31166 is a high-severity vulnerability in Xwiki Xwiki, published on 7 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform Old Core is a core package for XWiki Platform, a generic wiki platform. Starting in versions 11.3.7, 11.0.3, and 12.0RC1, it is possible to exploit a bug in XWikiRights resolution of groups to obtain privilege escalation. More specifically, editing a right with the object editor leads to adding a supplementary empty value to groups which is then resolved as a reference to XWiki.WebHome page. Adding an XWikiGroup xobject to that page then transforms it to a group, any user put in that group would then obtain the privileges related to the edited right. Note that this security issue is normally mitigated by the fact that XWiki.WebHome (and XWiki space in general) should be protected by default for edit rights. The problem has been patched in XWiki 13.10.4 and 14.2RC1 to not consider anymore empty values in XWikiRights. It's possible to work around the problem by setting appropriate rights on XWiki.WebHome page to prevent users to edit it.

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2022-31166?

4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 11.3.7 | 13.10.4 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 11.3.7 | 13.10.4 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0-rc-1 | 14.2-rc-1 |
| `org.xwiki.platform:xwiki-platform-oldcore` | Maven | From 14.0-rc-1 | 14.2-rc-1 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-31166?

Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 13.10.4 or 14.2-rc-1.

## Is CVE-2022-31166 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31166 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31166 and fix it if it is affected.

What it is: CVE-2022-31166 is a high-severity vulnerability in Xwiki Xwiki, published on 7 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31166 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 11.3.7; fixed in 13.10.4
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 11.3.7; fixed in 13.10.4
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0-rc-1; fixed in 14.2-rc-1
- org.xwiki.platform:xwiki-platform-oldcore (Maven): affected from 14.0-rc-1; fixed in 14.2-rc-1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31166/ (Markdown: https://insights.sbomify.com/CVE-2022-31166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31166
- OSV: https://osv.dev/vulnerability/CVE-2022-31166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31166/
Summaries are generated and may contain mistakes; the official description above is the record.
