CVE-2022-31167 XWiki Platform Security Parent POM vulnerable to overwriting of security rules of a page with a final page having the same reference
Attackers can overwrite security rules for spaces or documents by exploiting a cache collision, leading to unauthorized access or privilege escalation.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2022-31167?
CVE-2022-31167 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 7 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
XWiki Platform Security Parent POM contains the security APIs for XWiki Platform, a generic wiki platform. Starting with version 5.0 and prior to 12.10.11, 13.10.1, and 13.4.6, a bug in the security cache stores rules associated to document Page1.Page2 and space Page1.Page2 in the same cache entry. That means that it's possible to overwrite the rights of a space or a document by creating the page of the space with the same name and checking the right of the new one first so that they end up in the security cache and are used for the other too. The problem has been patched in XWiki 12.10.11, 13.10.1, and 13.4.6. There are no known workarounds.
Which versions are affected by CVE-2022-31167?
6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-security Maven | From 13.0 | 13.4.6 |
org.xwiki.platform:xwiki-platform-security Maven | From 13.0 | 13.4.6 |
org.xwiki.platform:xwiki-platform-security Maven | From 13.10 | 13.10.1 |
org.xwiki.platform:xwiki-platform-security Maven | From 13.10 | 13.10.1 |
org.xwiki.platform:xwiki-platform-security Maven | From 5.0 | 12.10.11 |
org.xwiki.platform:xwiki-platform-security Maven | From 5.0 | 12.10.11 |
Products include Xwiki Xwiki.
How do I fix CVE-2022-31167?
Upgrade org.xwiki.platform:xwiki-platform-security to a fixed version for your release line: 13.4.6, 13.10.1 or 12.10.11.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2022-31167 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31167 exists.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-gg53-wf5x-r3r6.