# CVE-2022-31167: XWiki Platform Security Parent POM vulnerable to overwriting of security rules of a page with a final page having the same reference

> Attackers can overwrite security rules for spaces or documents by exploiting a cache collision, leading to unauthorized access or privilege escalation.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Sep 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-gg53-wf5x-r3r6

## What is CVE-2022-31167?

CVE-2022-31167 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 7 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

XWiki Platform Security Parent POM contains the security APIs for XWiki Platform, a generic wiki platform. Starting with version 5.0 and prior to 12.10.11, 13.10.1, and 13.4.6, a bug in the security cache stores rules associated to document Page1.Page2 and space Page1.Page2 in the same cache entry. That means that it's possible to overwrite the rights of a space or a document by creating the page of the space with the same name and checking the right of the new one first so that they end up in the security cache and are used for the other too. The problem has been patched in XWiki 12.10.11, 13.10.1, and 13.4.6. There are no known workarounds.

Weakness: CWE-862 (Missing Authorization), CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2022-31167?

6 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-security. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.xwiki.platform:xwiki-platform-security` | Maven | From 13.0 | 13.4.6 |
| `org.xwiki.platform:xwiki-platform-security` | Maven | From 13.0 | 13.4.6 |
| `org.xwiki.platform:xwiki-platform-security` | Maven | From 13.10 | 13.10.1 |
| `org.xwiki.platform:xwiki-platform-security` | Maven | From 13.10 | 13.10.1 |
| `org.xwiki.platform:xwiki-platform-security` | Maven | From 5.0 | 12.10.11 |
| `org.xwiki.platform:xwiki-platform-security` | Maven | From 5.0 | 12.10.11 |

Products: Xwiki Xwiki.

## How do I fix CVE-2022-31167?

Upgrade org.xwiki.platform:xwiki-platform-security to a fixed version for your release line: 13.4.6, 13.10.1 or 12.10.11.

## Is CVE-2022-31167 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31167 exists.

## Other vulnerabilities in Xwiki Xwiki

- [CVE-2025-24893](https://insights.sbomify.com/CVE-2025-24893/): XWiki Platform Eval Injection (critical 9.8, exploited in the wild)
- [CVE-2025-53836](https://insights.sbomify.com/CVE-2025-53836/): XWiki Rendering is vulnerable to RCE attacks when processing nested macros (critical 10.0)
- [CVE-2024-55662](https://insights.sbomify.com/CVE-2024-55662/): XWiki allows remote code execution through the extension sheet (critical 10.0)
- [CVE-2024-55877](https://insights.sbomify.com/CVE-2024-55877/): XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList (critical 10.0)
- [CVE-2024-37901](https://insights.sbomify.com/CVE-2024-37901/): XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31167 and fix it if it is affected.

What it is: CVE-2022-31167 is a high-severity missing authorization vulnerability in Xwiki Xwiki, published on 7 Sep 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31167 exists.

Affected packages and fixed versions:
- org.xwiki.platform:xwiki-platform-security (Maven): affected from 13.0; fixed in 13.4.6
- org.xwiki.platform:xwiki-platform-security (Maven): affected from 13.0; fixed in 13.4.6
- org.xwiki.platform:xwiki-platform-security (Maven): affected from 13.10; fixed in 13.10.1
- org.xwiki.platform:xwiki-platform-security (Maven): affected from 13.10; fixed in 13.10.1
- org.xwiki.platform:xwiki-platform-security (Maven): affected from 5.0; fixed in 12.10.11
- org.xwiki.platform:xwiki-platform-security (Maven): affected from 5.0; fixed in 12.10.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31167/ (Markdown: https://insights.sbomify.com/CVE-2022-31167/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31167
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31167
- OSV: https://osv.dev/vulnerability/CVE-2022-31167

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31167/
Summaries are generated and may contain mistakes; the official description above is the record.
