{"answers":{"affected":"4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 1 product.","exploited":"There is no known exploitation of CVE-2022-31170 in the wild and no public exploit code.","fix":"Upgrade @openzeppelin/contracts to 4.7.1 or later.","what":"CVE-2022-31170 is a high-severity denial of service vulnerability in openzeppelin-contracts, published on 21 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31170 and fix it if it is affected.\n\nWhat it is: CVE-2022-31170 is a high-severity denial of service vulnerability in openzeppelin-contracts, published on 21 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2022-31170 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- @openzeppelin/contracts (npm): affected from 4.0.0; fixed in 4.7.1\n- @openzeppelin/contracts (npm): affected from 4.0.0; fixed in 4.7.1\n- @openzeppelin/contracts-upgradeable (npm): affected from 4.0.0; fixed in 4.7.1\n- @openzeppelin/contracts-upgradeable (npm): affected from 4.0.0; fixed in 4.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31170/ (Markdown: https://insights.sbomify.com/CVE-2022-31170/index.md)","id":"CVE-2022-31170","markdown":"https://insights.sbomify.com/CVE-2022-31170/index.md","name":"CVE-2022-31170","record":{"aliases":["GHSA-qh9x-gcfh-pcrw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Smart contract library","requires_auth":"none","summary":"Attackers can cause smart contracts to revert unexpectedly by interacting with non-compliant EIP-165 targets, disrupting contract logic.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"contracts","vendor":"openzeppelin"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-252","name":"Unchecked Return Value"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"OpenZeppelin Contracts is a library for smart contract development. Versions 4.0.0 until 4.7.1 are vulnerable to ERC165Checker reverting instead of returning `false`. `ERC165Checker.supportsInterface` is designed to always successfully return a boolean, and under no circumstance revert. However, an incorrect assumption about Solidity 0.8's `abi.decode` allows some cases to revert, given a target contract that doesn't implement EIP-165 as expected, specifically if it returns a value other than 0 or 1. The contracts that may be affected are those that use `ERC165Checker` to check for support for an interface and then handle the lack of support in a way other than reverting. The issue was patched in version 4.7.1.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenZeppelin Contracts's ERC165Checker may revert instead of returning false","id":"CVE-2022-31170","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":4,"n_references":2,"next":{"headline":"OpenZeppelin Contracts's SignatureChecker may revert on invalid EIP-1271 signers","id":"CVE-2022-31172"},"packages":[{"ecosystem":"npm","fixed":["4.7.1"],"introduced":["4.0.0"],"last_affected":[],"package":"@openzeppelin/contracts","purl":null,"source":"GHSA-qh9x-gcfh-pcrw"},{"ecosystem":"npm","fixed":["4.7.1"],"introduced":["4.0.0"],"last_affected":[],"package":"@openzeppelin/contracts","purl":"pkg:npm/%40openzeppelin/contracts","source":"GHSA-qh9x-gcfh-pcrw"},{"ecosystem":"npm","fixed":["4.7.1"],"introduced":["4.0.0"],"last_affected":[],"package":"@openzeppelin/contracts-upgradeable","purl":null,"source":"GHSA-qh9x-gcfh-pcrw"},{"ecosystem":"npm","fixed":["4.7.1"],"introduced":["4.0.0"],"last_affected":[],"package":"@openzeppelin/contracts-upgradeable","purl":"pkg:npm/%40openzeppelin/contracts-upgradeable","source":"GHSA-qh9x-gcfh-pcrw"}],"prev":{"headline":"Cranelift vulnerable to miscompilation of constant values in division on AArch64","id":"CVE-2022-31169"},"products":["openzeppelin-contracts"],"published":"2022-07-21","related":[{"cvss_score":10,"headline":"TimelockController vulnerability in OpenZeppelin Contracts","id":"CVE-2021-39167","kev_date_added":null,"published":"2021-08-26"},{"cvss_score":10,"headline":"TimelockController vulnerability in OpenZeppelin Contracts","id":"CVE-2021-39168","kev_date_added":null,"published":"2021-08-26"},{"cvss_score":9.8,"headline":"UUPSUpgradeable vulnerability in OpenZeppelin Contracts","id":"CVE-2021-41264","kev_date_added":null,"published":"2021-11-12"},{"cvss_score":7.9,"headline":"ECDSA signature malleability in OpenZeppelin Contracts","id":"CVE-2022-35961","kev_date_added":null,"published":"2022-08-14"},{"cvss_score":7.5,"headline":"GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts","id":"CVE-2022-31198","kev_date_added":null,"published":"2022-08-01"},{"cvss_score":7.5,"headline":"OpenZeppelin Contracts's SignatureChecker may revert on invalid EIP-1271 signers","id":"CVE-2022-31172","kev_date_added":null,"published":"2022-07-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["OpenZeppelin"]},"summary":"Attackers can cause smart contracts to revert unexpectedly by interacting with non-compliant EIP-165 targets, disrupting contract logic.","url":"https://insights.sbomify.com/CVE-2022-31170/"}