# CVE-2022-31172: OpenZeppelin Contracts's SignatureChecker may revert on invalid EIP-1271 signers

> Attackers can cause smart contracts using OpenZeppelin's SignatureChecker to revert unexpectedly when interacting with non-compliant EIP-1271 signers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jul 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-4g63-c64m-25w9

## What is CVE-2022-31172?

CVE-2022-31172 is a high-severity denial of service vulnerability in openzeppelin-contracts, published on 21 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenZeppelin Contracts is a library for smart contract development. Versions 4.1.0 until 4.7.1 are vulnerable to the SignatureChecker reverting. `SignatureChecker.isValidSignatureNow` is not expected to revert. However, an incorrect assumption about Solidity 0.8's `abi.decode` allows some cases to revert, given a target contract that doesn't implement EIP-1271 as expected. The contracts that may be affected are those that use `SignatureChecker` to check the validity of a signature and handle invalid signatures in a way other than reverting. The issue was patched in version 4.7.1.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2022-31172?

4 open source packages ship an affected version, including @openzeppelin/contracts and @openzeppelin/contracts-upgradeable. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@openzeppelin/contracts` | npm | From 4.1.0 | 4.7.1 |
| `@openzeppelin/contracts` | npm | From 4.1.0 | 4.7.1 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.1.0 | 4.7.1 |
| `@openzeppelin/contracts-upgradeable` | npm | From 4.1.0 | 4.7.1 |

Products: Openzeppelin Contracts.

## How do I fix CVE-2022-31172?

Upgrade @openzeppelin/contracts to 4.7.1 or later.

## Is CVE-2022-31172 being exploited?

There is no known exploitation of CVE-2022-31172 in the wild and no public exploit code.

## Other vulnerabilities in openzeppelin-contracts

- [CVE-2021-39167](https://insights.sbomify.com/CVE-2021-39167/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-39168](https://insights.sbomify.com/CVE-2021-39168/): TimelockController vulnerability in OpenZeppelin Contracts (critical 10.0)
- [CVE-2021-41264](https://insights.sbomify.com/CVE-2021-41264/): UUPSUpgradeable vulnerability in OpenZeppelin Contracts (critical 9.8)
- [CVE-2022-35961](https://insights.sbomify.com/CVE-2022-35961/): ECDSA signature malleability in OpenZeppelin Contracts (high 7.9)
- [CVE-2022-31198](https://insights.sbomify.com/CVE-2022-31198/): GovernorVotesQuorumFraction updates to quorum may affect past defeated proposals in @openzeppelin/contracts (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31172 and fix it if it is affected.

What it is: CVE-2022-31172 is a high-severity denial of service vulnerability in openzeppelin-contracts, published on 21 Jul 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31172 in the wild and no public exploit code.

Affected packages and fixed versions:
- @openzeppelin/contracts (npm): affected from 4.1.0; fixed in 4.7.1
- @openzeppelin/contracts (npm): affected from 4.1.0; fixed in 4.7.1
- @openzeppelin/contracts-upgradeable (npm): affected from 4.1.0; fixed in 4.7.1
- @openzeppelin/contracts-upgradeable (npm): affected from 4.1.0; fixed in 4.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31172/ (Markdown: https://insights.sbomify.com/CVE-2022-31172/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31172
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31172
- OSV: https://osv.dev/vulnerability/CVE-2022-31172

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31172/
Summaries are generated and may contain mistakes; the official description above is the record.
