{"answers":{"affected":"6 open source packages ship an affected version, including juniper and async-graphql. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31173 exists.","fix":"Upgrade juniper to 0.15.10 or later.","what":"CVE-2022-31173 is a high-severity denial of service vulnerability in graphql-rust juniper, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31173 and fix it if it is affected.\n\nWhat it is: CVE-2022-31173 is a high-severity denial of service vulnerability in graphql-rust juniper, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31173 exists.\n\nAffected packages and fixed versions:\n- juniper (crates.io): affected all versions; fixed in 0.15.10\n- juniper (crates.io): affected all versions; fixed in 0.15.10\n- juniper (crates.io): affected from 0.0.0-0; fixed in 0.15.10\n- async-graphql (crates.io): affected all versions; fixed in 4.0.6\n- async-graphql (crates.io): affected all versions; fixed in 4.0.6\n- async-graphql (crates.io): affected from 0.0.0-0; fixed in 4.0.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31173/ (Markdown: https://insights.sbomify.com/CVE-2022-31173/index.md)","id":"CVE-2022-31173","markdown":"https://insights.sbomify.com/CVE-2022-31173/index.md","name":"CVE-2022-31173","record":{"aliases":["GHSA-4rx6-g5vg-5f3j","GHSA-xq3c-8gqm-v648","RUSTSEC-2022-0037","RUSTSEC-2022-0038"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust GraphQL library","requires_auth":"none","summary":"Attackers can crash the application by sending deeply nested GraphQL fragments, causing a denial of service in the Juniper library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"juniper","vendor":"juniper_project"}],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"},{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"Juniper is a GraphQL server library for Rust. Affected versions of Juniper are vulnerable to uncontrolled recursion resulting in a program crash. This issue has been addressed in version 0.15.10. Users are advised to upgrade. Users unable to upgrade should limit the recursion depth manually.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Juniper is vulnerable to @DOS GraphQL Nested Fragments overflow","id":"CVE-2022-31173","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":6,"n_references":4,"next":{"headline":"Cross-site scripting caused by the editor instance destroying process in ckeditor5","id":"CVE-2022-31175"},"packages":[{"ecosystem":"crates.io","fixed":["4.0.6"],"introduced":["0"],"last_affected":[],"package":"async-graphql","purl":null,"source":"GHSA-xq3c-8gqm-v648"},{"ecosystem":"crates.io","fixed":["4.0.6"],"introduced":["0"],"last_affected":[],"package":"async-graphql","purl":"pkg:cargo/async-graphql","source":"GHSA-xq3c-8gqm-v648"},{"ecosystem":"crates.io","fixed":["4.0.6"],"introduced":["0.0.0-0"],"last_affected":[],"package":"async-graphql","purl":"pkg:cargo/async-graphql","source":"RUSTSEC-2022-0037"},{"ecosystem":"crates.io","fixed":["0.15.10"],"introduced":["0"],"last_affected":[],"package":"juniper","purl":null,"source":"GHSA-4rx6-g5vg-5f3j"},{"ecosystem":"crates.io","fixed":["0.15.10"],"introduced":["0"],"last_affected":[],"package":"juniper","purl":"pkg:cargo/juniper","source":"GHSA-4rx6-g5vg-5f3j"},{"ecosystem":"crates.io","fixed":["0.15.10"],"introduced":["0.0.0-0"],"last_affected":[],"package":"juniper","purl":"pkg:cargo/juniper","source":"RUSTSEC-2022-0038"}],"prev":{"headline":"OpenZeppelin Contracts's SignatureChecker may revert on invalid EIP-1271 signers","id":"CVE-2022-31172"},"products":["juniper"],"published":"2022-08-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-22","vendors":["graphql-rust"]},"summary":"Attackers can crash the application by sending deeply nested GraphQL fragments, causing a denial of service in the Juniper library.","url":"https://insights.sbomify.com/CVE-2022-31173/"}