# CVE-2022-31173: Juniper is vulnerable to @DOS GraphQL Nested Fragments overflow

> Attackers can crash the application by sending deeply nested GraphQL fragments, causing a denial of service in the Juniper library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 22 Apr 2025
- **Also known as:** GHSA-4rx6-g5vg-5f3j, GHSA-xq3c-8gqm-v648, RUSTSEC-2022-0037, RUSTSEC-2022-0038

## What is CVE-2022-31173?

CVE-2022-31173 is a high-severity denial of service vulnerability in graphql-rust juniper, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Juniper is a GraphQL server library for Rust. Affected versions of Juniper are vulnerable to uncontrolled recursion resulting in a program crash. This issue has been addressed in version 0.15.10. Users are advised to upgrade. Users unable to upgrade should limit the recursion depth manually.

Weakness: CWE-674 (Uncontrolled Recursion), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2022-31173?

6 open source packages ship an affected version, including juniper and async-graphql. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `juniper` | crates.io | All versions | 0.15.10 |
| `juniper` | crates.io | All versions | 0.15.10 |
| `juniper` | crates.io | From 0.0.0-0 | 0.15.10 |
| `async-graphql` | crates.io | All versions | 4.0.6 |
| `async-graphql` | crates.io | All versions | 4.0.6 |
| `async-graphql` | crates.io | From 0.0.0-0 | 4.0.6 |

Products: Juniper Project Juniper.

## How do I fix CVE-2022-31173?

Upgrade juniper to 0.15.10 or later.

## Is CVE-2022-31173 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31173 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31173 and fix it if it is affected.

What it is: CVE-2022-31173 is a high-severity denial of service vulnerability in graphql-rust juniper, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31173 exists.

Affected packages and fixed versions:
- juniper (crates.io): affected all versions; fixed in 0.15.10
- juniper (crates.io): affected all versions; fixed in 0.15.10
- juniper (crates.io): affected from 0.0.0-0; fixed in 0.15.10
- async-graphql (crates.io): affected all versions; fixed in 4.0.6
- async-graphql (crates.io): affected all versions; fixed in 4.0.6
- async-graphql (crates.io): affected from 0.0.0-0; fixed in 4.0.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31173/ (Markdown: https://insights.sbomify.com/CVE-2022-31173/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31173
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31173
- OSV: https://osv.dev/vulnerability/CVE-2022-31173

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31173/
Summaries are generated and may contain mistakes; the official description above is the record.
