# CVE-2022-31176: Grafana Image Renderer leaking files


- **Severity:** High 8.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 2 Sep 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-grafana-image-renderer-2022-31176, GHSA-2cfh-233g-m4c5

## What is CVE-2022-31176?

CVE-2022-31176 is a high-severity vulnerability in grafana-image-renderer, published on 2 Sep 2022. 

### Official description

Grafana Image Renderer is a Grafana backend plugin that handles rendering of panels & dashboards to PNGs using a headless browser (Chromium/Chrome). An internal security review identified an unauthorized file disclosure vulnerability. It is possible for a malicious user to retrieve unauthorized files under some network conditions or via a fake datasource (if user has admin permissions in Grafana). All Grafana installations should be upgraded to version 3.6.1 as soon as possible. As a workaround it is possible to [disable HTTP remote rendering](https://grafana.com/docs/grafana/latest/setup-grafana/configure-grafana/#plugingrafana-image-renderer).

Weakness: CWE-306 (Missing Authentication for Critical Functionality), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-31176?

1 open source package ship an affected version, including grafana-image-renderer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `grafana-image-renderer` | Bitnami | All versions | 3.6.1 |

Products: Grafana Grafana-Image-Renderer.

## How do I fix CVE-2022-31176?

Upgrade grafana-image-renderer to 3.6.1 or later.

## Is CVE-2022-31176 being exploited?

There is no known exploitation of CVE-2022-31176 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31176 and fix it if it is affected.

What it is: CVE-2022-31176 is a high-severity vulnerability in grafana-image-renderer, published on 2 Sep 2022. 
Exploitation: There is no known exploitation of CVE-2022-31176 in the wild and no public exploit code.

Affected packages and fixed versions:
- grafana-image-renderer (Bitnami): affected all versions; fixed in 3.6.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31176/ (Markdown: https://insights.sbomify.com/CVE-2022-31176/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31176
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31176
- OSV: https://osv.dev/vulnerability/CVE-2022-31176

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31176/
Summaries are generated and may contain mistakes; the official description above is the record.
