# CVE-2022-31177: Possible to infer sensitive information through query strings in Flask-AppBuilder

> An authenticated admin can infer partial password hashes of other users via query filters, exposing sensitive credential data.

- **Severity:** Low 2.7 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-32ff-4g79-vgfc, PYSEC-2022-247

## What is CVE-2022-31177?

CVE-2022-31177 is a low-severity vulnerability in dpgaspar Flask-AppBuilder, published on 1 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Flask-AppBuilder is an application development framework built on top of Flask python framework. In versions prior to 4.1.3 an authenticated Admin user could query other users by their salted and hashed passwords strings. These filters could be made by using partial hashed password strings. The response would not include the hashed passwords, but an attacker could infer partial password hashes and their respective users. This issue has been fixed in version 4.1.3. Users are advised to upgrade. There are no known workarounds for this issue.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2022-31177?

3 open source packages ship an affected version, including flask-appbuilder and Flask-AppBuilder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-appbuilder` | PyPI | All versions | 4.1.3 |
| `flask-appbuilder` | PyPI | All versions | 4.1.3 |
| `Flask-AppBuilder` | PyPI | All versions | 4.1.3 |

Products: Dpgaspar Flask-Appbuilder.

## How do I fix CVE-2022-31177?

Upgrade flask-appbuilder to 4.1.3 or later.

## Is CVE-2022-31177 being exploited?

There is no known exploitation of CVE-2022-31177 in the wild and no public exploit code.

## Other vulnerabilities in dpgaspar Flask-AppBuilder

- [CVE-2024-25128](https://insights.sbomify.com/CVE-2024-25128/): Flask-AppBuilder incorrect authentication when using auth type OpenID (critical 9.1)
- [CVE-2021-41265](https://insights.sbomify.com/CVE-2021-41265/): Improper Authentication in Flask-AppBuilder (high 8.1)
- [CVE-2023-29005](https://insights.sbomify.com/CVE-2023-29005/): No Rate Limiting on Login AUTH DB (high 7.5)
- [CVE-2021-32805](https://insights.sbomify.com/CVE-2021-32805/): URL Redirection to Untrusted Site ('Open Redirect') in Flask-AppBuilder (high 7.2)
- [CVE-2025-58065](https://insights.sbomify.com/CVE-2025-58065/): Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31177 and fix it if it is affected.

What it is: CVE-2022-31177 is a low-severity vulnerability in dpgaspar Flask-AppBuilder, published on 1 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31177 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-appbuilder (PyPI): affected all versions; fixed in 4.1.3
- flask-appbuilder (PyPI): affected all versions; fixed in 4.1.3
- Flask-AppBuilder (PyPI): affected all versions; fixed in 4.1.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31177/ (Markdown: https://insights.sbomify.com/CVE-2022-31177/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31177
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31177
- OSV: https://osv.dev/vulnerability/CVE-2022-31177

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31177/
Summaries are generated and may contain mistakes; the official description above is the record.
