{"answers":{"affected":"2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31181 exists.","fix":"Upgrade prestashop/prestashop to 1.7.8.7 or later.","what":"CVE-2022-31181 is a critical SQL injection vulnerability in Prestashop Prestashop, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2022-31181 and fix it if it is affected.\n\nWhat it is: CVE-2022-31181 is a critical SQL injection vulnerability in Prestashop Prestashop, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31181 exists.\n\nAffected packages and fixed versions:\n- prestashop/prestashop (Packagist): affected from 1.6.0.10; fixed in 1.7.8.7\n- prestashop/prestashop (Packagist): affected from 1.6.0.10; fixed in 1.7.8.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2022-31181/ (Markdown: https://insights.sbomify.com/CVE-2022-31181/index.md)","id":"CVE-2022-31181","markdown":"https://insights.sbomify.com/CVE-2022-31181/index.md","name":"CVE-2022-31181","record":{"aliases":["CVE-2022-36408","GHSA-hrgx-p36p-89q4"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"E-commerce platform","requires_auth":"none","summary":"Attackers can exploit SQL injection to execute arbitrary code via PHP eval, requiring an upgrade to PrestaShop.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"prestashop","vendor":"prestashop"}],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"},{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"}],"description":"PrestaShop is an Open Source e-commerce platform. In versions from 1.6.0.10 and before 1.7.8.7 PrestaShop is subject to an SQL injection vulnerability which can be chained to call PHP's Eval function on attacker input. The problem is fixed in version 1.7.8.7. Users are advised to upgrade. Users unable to upgrade may delete the MySQL Smarty cache feature.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":"2022-07-26","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":1,"refs":[{"date":"2022-07-26T05:55:53Z","kind":"github_poc","ref":"https://github.com/drkbcn/lblfixer_cve_2022_31181","stars":0,"title":"Module for PrestaShop 1.6.1.X/1.7.X to fix CVE-2022-31181 / CVE-2022-36408 vulnerability (Chain SQL Injection)"},{"date":null,"kind":"nuclei","ref":"http/cves/2022/CVE-2022-31181.yaml","stars":null,"title":"PrestaShop - SQL Injection to Eval Injection"}],"tier":"weaponised"},"has_fix":true,"headline":"Remote code execution in prestashop","id":"CVE-2022-31181","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"prestashop:prestashop","products":["prestashop:prestashop"],"type":"sql_injection","year":"2022"},"n_packages":2,"n_references":3,"next":{"headline":"Cache poisoning via maliciously-formed request in Discourse","id":"CVE-2022-31182"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.8.7"],"introduced":["1.6.0.10"],"last_affected":[],"package":"prestashop/prestashop","purl":null,"source":"GHSA-hrgx-p36p-89q4"},{"ecosystem":"Packagist","fixed":["1.7.8.7"],"introduced":["1.6.0.10"],"last_affected":[],"package":"prestashop/prestashop","purl":"pkg:composer/prestashop/prestashop","source":"GHSA-hrgx-p36p-89q4"}],"prev":{"headline":"Insufficient escaping of whitespace in shescape","id":"CVE-2022-31180"},"products":["PrestaShop"],"published":"2022-08-01","related":[{"cvss_score":10,"headline":"PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using \"SQL Manager\"","id":"CVE-2023-30839","kev_date_added":null,"published":"2023-04-25"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2008-5791","kev_date_added":null,"published":"2008-12-31"},{"cvss_score":9.8,"headline":"Server-side request forgery in n/a","id":"CVE-2024-41651","kev_date_added":null,"published":"2024-08-12"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2021-3110","kev_date_added":null,"published":"2021-01-20"},{"cvss_score":9.8,"headline":"Blind SQL Injection in PrestaShop","id":"CVE-2020-15160","kev_date_added":null,"published":"2020-09-24"},{"cvss_score":9.8,"headline":"Privilege escalation in n/a","id":"CVE-2013-6295","kev_date_added":null,"published":"2020-02-18"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"MIT","name":"Nuclei templates"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-04-23","vendors":["PrestaShop"]},"summary":"Attackers can exploit SQL injection to execute arbitrary code via PHP eval, requiring an upgrade to PrestaShop.","url":"https://insights.sbomify.com/CVE-2022-31181/"}