# CVE-2022-31181: Remote code execution in prestashop

> Attackers can exploit SQL injection to execute arbitrary code via PHP eval, requiring an upgrade to PrestaShop.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** CVE-2022-36408, GHSA-hrgx-p36p-89q4

## What is CVE-2022-31181?

CVE-2022-31181 is a critical SQL injection vulnerability in Prestashop Prestashop, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PrestaShop is an Open Source e-commerce platform. In versions from 1.6.0.10 and before 1.7.8.7 PrestaShop is subject to an SQL injection vulnerability which can be chained to call PHP's Eval function on attacker input. The problem is fixed in version 1.7.8.7. Users are advised to upgrade. Users unable to upgrade may delete the MySQL Smarty cache feature.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command), CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2022-31181?

2 open source packages ship an affected version, including prestashop/prestashop. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/prestashop` | Packagist | From 1.6.0.10 | 1.7.8.7 |
| `prestashop/prestashop` | Packagist | From 1.6.0.10 | 1.7.8.7 |

Products: Prestashop Prestashop.

## How do I fix CVE-2022-31181?

Upgrade prestashop/prestashop to 1.7.8.7 or later.

## Is CVE-2022-31181 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31181 exists.

Public exploit code:

- Module for PrestaShop 1.6.1.X/1.7.X to fix CVE-2022-31181 / CVE-2022-36408 vulnerability (Chain SQL Injection) (github_poc): https://github.com/drkbcn/lblfixer_cve_2022_31181
- PrestaShop - SQL Injection to Eval Injection (nuclei): http/cves/2022/CVE-2022-31181.yaml

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)
- [CVE-2020-15160](https://insights.sbomify.com/CVE-2020-15160/): Blind SQL Injection in PrestaShop (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31181 and fix it if it is affected.

What it is: CVE-2022-31181 is a critical SQL injection vulnerability in Prestashop Prestashop, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2022-31181 exists.

Affected packages and fixed versions:
- prestashop/prestashop (Packagist): affected from 1.6.0.10; fixed in 1.7.8.7
- prestashop/prestashop (Packagist): affected from 1.6.0.10; fixed in 1.7.8.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31181/ (Markdown: https://insights.sbomify.com/CVE-2022-31181/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31181
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31181
- OSV: https://osv.dev/vulnerability/CVE-2022-31181

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31181/
Summaries are generated and may contain mistakes; the official description above is the record.
