# CVE-2022-31182: Cache poisoning via maliciously-formed request in Discourse


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** BIT-discourse-2022-31182, GHSA-4ff8-3j78-w6pp

## What is CVE-2022-31182?

CVE-2022-31182 is a medium-severity vulnerability in Discourse Discourse, published on 1 Aug 2022. 

### Official description

Discourse is the an open source discussion platform. In affected versions a maliciously crafted request for static assets could cause error responses to be cached by Discourse's default NGINX proxy configuration. A corrected NGINX configuration is included in the latest stable, beta and tests-passed versions of Discourse. Users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2022-31182?

1 open source package ship an affected version, including discourse. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `discourse` | Bitnami | All versions | 2.8.7 |

Products: Discourse Discourse.

## How do I fix CVE-2022-31182?

Upgrade discourse to 2.8.7 or later.

## Is CVE-2022-31182 being exploited?

There is no known exploitation of CVE-2022-31182 in the wild and no public exploit code.

## Other vulnerabilities in Discourse Discourse

- [CVE-2021-41163](https://insights.sbomify.com/CVE-2021-41163/): RCE via malicious SNS subscription payload (critical 10.0)
- [CVE-2022-36066](https://insights.sbomify.com/CVE-2022-36066/): Discourse vulnerable to RCE via admins uploading maliciously zipped file (critical 9.1)
- [CVE-2022-39356](https://insights.sbomify.com/CVE-2022-39356/): Discourse user account takeover via email and invite link (high 8.9)
- [CVE-2023-22468](https://insights.sbomify.com/CVE-2023-22468/): Discourse vulnerable to Cross-site Scripting in local oneboxes (high 8.8)
- [CVE-2026-27934](https://insights.sbomify.com/CVE-2026-27934/): Discourse leaks private topic title and post excerpt via user action API endpoint (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31182 and fix it if it is affected.

What it is: CVE-2022-31182 is a medium-severity vulnerability in Discourse Discourse, published on 1 Aug 2022. 
Exploitation: There is no known exploitation of CVE-2022-31182 in the wild and no public exploit code.

Affected packages and fixed versions:
- discourse (Bitnami): affected all versions; fixed in 2.8.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31182/ (Markdown: https://insights.sbomify.com/CVE-2022-31182/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31182
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31182
- OSV: https://osv.dev/vulnerability/CVE-2022-31182

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31182/
Summaries are generated and may contain mistakes; the official description above is the record.
