# CVE-2022-31186: Leakage of excessive information into log in next-auth

> Attackers with log access can obtain OAuth secrets from NextAuth.js logs, enabling client impersonation and permission escalation.

- **Severity:** Low 3.3 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-p6mm-27gq-9v3p

## What is CVE-2022-31186?

CVE-2022-31186 is a low-severity vulnerability in nextauthjs next-auth, published on 1 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

NextAuth.js is a complete open source authentication solution for Next.js applications. An information disclosure vulnerability in `next-auth` before `v4.10.2` and `v3.29.9` allows an attacker with log access privilege to obtain excessive information such as an identity provider's secret in the log (which is thrown during OAuth error handling) and use it to leverage further attacks on the system, like impersonating the client to ask for extensive permissions. This issue has been patched in `v4.10.2` and `v3.29.9` by moving the log for `provider` information to the debug level. In addition, we added a warning for having the `debug: true` option turned on in production. If for some reason you cannot upgrade, you can user the `logger` configuration option by sanitizing the logs.

Weakness: CWE-532 (Insertion of Sensitive Information into Log File)

## Which versions are affected by CVE-2022-31186?

4 open source packages ship an affected version, including next-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `next-auth` | npm | All versions | 3.29.9 |
| `next-auth` | npm | All versions | 3.29.9 |
| `next-auth` | npm | From 4.0.0 | 4.10.2 |
| `next-auth` | npm | From 4.0.0 | 4.10.2 |

Products: Next-Auth Nextauth.js.

## How do I fix CVE-2022-31186?

Upgrade next-auth to a fixed version for your release line: 3.29.9 or 4.10.2.

## Is CVE-2022-31186 being exploited?

There is no known exploitation of CVE-2022-31186 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31186 and fix it if it is affected.

What it is: CVE-2022-31186 is a low-severity vulnerability in nextauthjs next-auth, published on 1 Aug 2022. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31186 in the wild and no public exploit code.

Affected packages and fixed versions:
- next-auth (npm): affected all versions; fixed in 3.29.9
- next-auth (npm): affected all versions; fixed in 3.29.9
- next-auth (npm): affected from 4.0.0; fixed in 4.10.2
- next-auth (npm): affected from 4.0.0; fixed in 4.10.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31186/ (Markdown: https://insights.sbomify.com/CVE-2022-31186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31186
- OSV: https://osv.dev/vulnerability/CVE-2022-31186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31186/
Summaries are generated and may contain mistakes; the official description above is the record.
