# CVE-2022-31193: URL Redirection to Untrusted Site in Dspace JSPUI

> Attackers can craft malicious URLs in DSpace JSPUI to redirect users to untrusted sites, potentially facilitating phishing attacks.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-763j-q7wv-vf3m

## What is CVE-2022-31193?

CVE-2022-31193 is a high-severity vulnerability in DSpace, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

DSpace open source software is a repository application which provides durable access to digital resources. dspace-jspui is a UI component for DSpace. The JSPUI controlled vocabulary servlet is vulnerable to an open redirect attack, where an attacker can craft a malicious URL that looks like a legitimate DSpace/repository URL. When that URL is clicked by the target, it redirects them to a site of the attacker's choice. This issue has been patched in versions 5.11 and 6.4. Users are advised to upgrade. There are no known workaround for this vulnerability.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2022-31193?

4 open source packages ship an affected version, including org.dspace:dspace-jspui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.dspace:dspace-jspui` | Maven | From 4.0 | 5.11 |
| `org.dspace:dspace-jspui` | Maven | From 4.0 | 5.11 |
| `org.dspace:dspace-jspui` | Maven | From 6.0 | 6.4 |
| `org.dspace:dspace-jspui` | Maven | From 6.0 | 6.4 |

Products: Duraspace Dspace.

## How do I fix CVE-2022-31193?

Upgrade org.dspace:dspace-jspui to a fixed version for your release line: 5.11 or 6.4.

## Is CVE-2022-31193 being exploited?

There is no known exploitation of CVE-2022-31193 in the wild and no public exploit code.

## Other vulnerabilities in DSpace

- [CVE-2022-31194](https://insights.sbomify.com/CVE-2022-31194/): Path traversal vulnerabilities in DSpace JSPUI submission upload (high 8.2)
- [CVE-2016-10726](https://insights.sbomify.com/CVE-2016-10726/): High severity vulnerability that affects org.dspace:dspace-xmlui (high 7.5)
- [CVE-2022-31195](https://insights.sbomify.com/CVE-2022-31195/): Path traversal vulnerability in Simple Archive Format package import in DSpace (high 7.2)
- [CVE-2021-41189](https://insights.sbomify.com/CVE-2021-41189/): Communities and collections administrators can escalate their privilege up to system administrator (high 7.2)
- [CVE-2022-31191](https://insights.sbomify.com/CVE-2022-31191/): Cross Site Scripting possible in DSpace JSPUI spellcheck and autocomplete tools (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31193 and fix it if it is affected.

What it is: CVE-2022-31193 is a high-severity vulnerability in DSpace, published on 1 Aug 2022. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2022-31193 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.dspace:dspace-jspui (Maven): affected from 4.0; fixed in 5.11
- org.dspace:dspace-jspui (Maven): affected from 4.0; fixed in 5.11
- org.dspace:dspace-jspui (Maven): affected from 6.0; fixed in 6.4
- org.dspace:dspace-jspui (Maven): affected from 6.0; fixed in 6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31193/ (Markdown: https://insights.sbomify.com/CVE-2022-31193/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31193
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31193
- OSV: https://osv.dev/vulnerability/CVE-2022-31193

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31193/
Summaries are generated and may contain mistakes; the official description above is the record.
