# CVE-2022-31194: Path traversal vulnerabilities in DSpace JSPUI submission upload

> Authenticated submitters can exploit path traversal in DSpace JSPUI to create files or directories anywhere on the server writable by the application user.

- **Severity:** High 8.2 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Aug 2022
- **Updated:** 23 Apr 2025
- **Also known as:** GHSA-qp5m-c3m9-8q2p

## What is CVE-2022-31194?

CVE-2022-31194 is a high-severity path traversal vulnerability in DSpace, published on 1 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

DSpace open source software is a repository application which provides durable access to digital resources. dspace-jspui is a UI component for DSpace. The JSPUI resumable upload implementations in SubmissionController and FileUploadRequest are vulnerable to multiple path traversal attacks, allowing an attacker to create files/directories anywhere on the server writable by the Tomcat/DSpace user, by modifying some request parameters during submission. This path traversal can only be executed by a user with special privileges (submitter rights). This vulnerability only impacts the JSPUI. Users are advised to upgrade. There are no known workarounds. However, this vulnerability cannot be exploited by an anonymous user or a basic user. The user must first have submitter privileges to at least one Collection and be able to determine how to modify the request parameters to exploit the vulnerability.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2022-31194?

4 open source packages ship an affected version, including org.dspace:dspace-jspui. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.dspace:dspace-jspui` | Maven | From 4.0 | 5.11 |
| `org.dspace:dspace-jspui` | Maven | From 4.0 | 5.11 |
| `org.dspace:dspace-jspui` | Maven | From 6.0 | 6.4 |
| `org.dspace:dspace-jspui` | Maven | From 6.0 | 6.4 |

Products: Duraspace Dspace.

## How do I fix CVE-2022-31194?

Upgrade org.dspace:dspace-jspui to a fixed version for your release line: 5.11 or 6.4.

## Is CVE-2022-31194 being exploited?

There is no known exploitation of CVE-2022-31194 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/DSpace__DSpace_CVE-2022-31194_5-10 (github_poc): https://github.com/shoucheng3/DSpace__DSpace_CVE-2022-31194_5-10

## Other vulnerabilities in DSpace

- [CVE-2016-10726](https://insights.sbomify.com/CVE-2016-10726/): High severity vulnerability that affects org.dspace:dspace-xmlui (high 7.5)
- [CVE-2022-31195](https://insights.sbomify.com/CVE-2022-31195/): Path traversal vulnerability in Simple Archive Format package import in DSpace (high 7.2)
- [CVE-2021-41189](https://insights.sbomify.com/CVE-2021-41189/): Communities and collections administrators can escalate their privilege up to system administrator (high 7.2)
- [CVE-2022-31191](https://insights.sbomify.com/CVE-2022-31191/): Cross Site Scripting possible in DSpace JSPUI spellcheck and autocomplete tools (high 7.1)
- [CVE-2022-31192](https://insights.sbomify.com/CVE-2022-31192/): Cross Site Scripting possible in DSpace JSPUI "Request a Copy" feature (high 7.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2022-31194 and fix it if it is affected.

What it is: CVE-2022-31194 is a high-severity path traversal vulnerability in DSpace, published on 1 Aug 2022. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2022-31194 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.dspace:dspace-jspui (Maven): affected from 4.0; fixed in 5.11
- org.dspace:dspace-jspui (Maven): affected from 4.0; fixed in 5.11
- org.dspace:dspace-jspui (Maven): affected from 6.0; fixed in 6.4
- org.dspace:dspace-jspui (Maven): affected from 6.0; fixed in 6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2022-31194/ (Markdown: https://insights.sbomify.com/CVE-2022-31194/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2022-31194
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2022-31194
- OSV: https://osv.dev/vulnerability/CVE-2022-31194

---
From sbomify Insights: https://insights.sbomify.com/CVE-2022-31194/
Summaries are generated and may contain mistakes; the official description above is the record.
